Ticket #7919 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

XO back up to XS, no data stored

Reported by: kimquirk Owned by: martin.langhoff
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: school server Version: not specified
Keywords: blocks:8.2.0 8.2-756:+ Cc: dsd, cscott, gregorio
Action Needed: test in build Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Joyride 2230, q2e12; XS build 165

I registered 3 laptops to the XS; and waited for them to complete an automatic update (days). I created a write document, a turtle art program, a paint doc.

You can see 2 other laptops that had registered and there is a 'datastore-current' directory that was created, but the date is 6/6, and 7/28. So I think those are old files; no new datastore files.

Looks like recent XO and XS code is not creating datastore back up files on the XS.

Change History

Changed 6 years ago by gregorio

  • cc gregorio added
  • keywords blocks:8.2.0 added; blocks?:8.2.0 removed

Backup and restore is a core feature.

I'm marking this a blocker unless/until the boss says otherwise :-)

Thanks,

Greg S

Changed 6 years ago by kimquirk

Can someone describe how to force the XO to do a backup so we don't have to wait? Also, what is the maximum time I would have to wait to get a backup? (Or point to a wiki page with this info).

Test cases associated with this testing:

Changed 6 years ago by kimquirk

Also, to get to the schoolserver we are using for testing, you currently need to use the IP address: 18.85.47.133.

Changed 6 years ago by martin.langhoff

I've added debugging hints to the wikipage - search for "To log the output" in http://wiki.laptop.org/go/XS_Blueprints:Datastore_Simple_Backup_and_Restore#Testing_the_backup_run

Thinking about what could be failing on the XOs -- at 1CC you have several mesh signals. It is very likely that the laptops are associated to the _wrong_ signal and schoolserver.

To check that this is not the case, look at the FQDN in /home/olpc/.sugar/default/profile with the 'search' domain in /etc/resolv.conf. Pinging 'schoolserver' will give you the LAN address and that one is always the same.

To help further - I need ssh access to 1 XO and the XS showing the problem

Changed 6 years ago by dsd

I'll help look into this when I can find Kim to point me to the appropriate XOs

Changed 6 years ago by dsd

The problem is that the cron.d entry is broken, it points to ds-backup.sh rather than ds_backup.sh

I see you've fixed this in 0.7, but that hasn't made it into joyride yet. Any particular reason why?

Changed 6 years ago by martin.langhoff

Damn! I thought it had -- I did check the joyride logs. No, no good reason. I did attach it to #7392 and understood it was in the builds.

Changed 6 years ago by martin.langhoff

dsd - I fixed things are suggested by dennis, but it's still not in the builds (2301 lists the old version). Perhaps you can chase Scott or Mstone and get them to sort things out with the build system? Much easier for you at 1CC than for me in NZ :-/

Changed 6 years ago by dsd

You didn't put a ChangeLog there, I think it is required. See ~dsd/public_rpms/joyride/ChangeLog for the required format.

Changed 6 years ago by martin.langhoff

In there now. Hopefully it'll be in the next run.

Changed 6 years ago by cscott

Martin, I've added your email address to the list which the package collection script uses; you should get email notification if your ChangeLog is deficient now.

Changed 6 years ago by dsd

  • next_action changed from diagnose to test in build

joyride-2311 includes the fixed backup client

Changed 6 years ago by dsd

  • keywords 8.2-756:+ added
  • status changed from new to closed
  • resolution set to fixed

confirmed working in 8.2-756

Note: See TracTickets for help on using tickets.