Opened 6 years ago

Last modified 6 years ago

#7972 reopened defect

Collaboration problems in infra mode

Reported by: carrano Owned by: Collabora
Priority: blocker Milestone: 9.1.0-cancelled
Component: telepathy-salut Version: not specified
Keywords: blocks-:8.2.0 joyide-2301:- Cc: dsaxena, morgs, dcbw, mtd, marco
Blocked By: Blocking: #7417
Deployments affected: Action Needed: diagnose
Verified: no

Description

Joyride 2292 and 2301 (installed with olpc-update) present problems with collaboration in the following scenario.

Two XOs connected to an access point (no school server, no jabber server).

Most important symptoms:

  • You can't rely that one XO will see the other in the neighbor view. Sometimes it will, sometimes it won't. And sometimes, A will see B, but B will not see A.
  • Even if the A sees B, and also icons for activities shared by B, A can join that activity but no traffic will reach B, at least from a user point of view (did not sniff to see if the frames were sent).

Notes:

  • It is possible for the XOs to ping each other with the eth0 address
  • If enabled to answer to broadcast pings, the XOs will even respond to each other pings to 224.0.0.1

Interesting remarks that may or may not be related (it's important to get repeatability here):

  • in one of the XOs there were two circles for the same access point
  • it all seems to work fine after the removal of the networks.cfg and a reboot.

I resisted the temptation to call this ticket "networks.cfg is causing us trouble", just because it could be a premature diagnoses.

Change History (19)

comment:1 Changed 6 years ago by dsaxena

  • Blocking 2, 8, 2301 added
  • Cc dsaxena added

comment:2 Changed 6 years ago by dsaxena

  • Blocking 2, 8, 2301 removed
  • Keywords blocks:8.2? joyide-2301:- added

comment:3 in reply to: ↑ description Changed 6 years ago by morgs

  • Cc morgs added

Replying to carrano:

Interesting remarks that may or may not be related (it's important to get repeatability here):

  • in one of the XOs there were two circles for the same access point

I logged this as #7415 a while back, seems to be Network Manager.

comment:4 Changed 6 years ago by gdesmott

Humm that sounds like yet another multicast issue. Will try to reproduce.

comment:5 Changed 6 years ago by morgs

Replying to carrano:

Most important symptoms:

  • You can't rely that one XO will see the other in the neighbor view. Sometimes it will, sometimes it won't. And sometimes, A will see B, but B will not see A.
  • Even if the A sees B, and also icons for activities shared by B, A can join that activity but no traffic will reach B, at least from a user point of view (did not sniff to see if the frames were sent).

I had this exact scenario yesterday, and yes, rebooting all the XOs "fixed" it.

Today, with 6 XOs on an AP, no jabber, it seems to just work, although just sharing Chat and joining on all of them and stopping all of them quickly gets things out of sync: Several couldn't see all the participants, and after stopping the activity on all of them, three still had the activity icon stuck on mesh view, and one of them still saw all the others "in" the activity.

This was a quick test - I'll do a more thorough test with salut logs enabled (http://wiki.laptop.org/go/Telepathy_debugging) and post them.

comment:6 Changed 6 years ago by cjb

We'd like Collabora to look at this one.

comment:7 Changed 6 years ago by gdesmott

As for #7893, we'd need salut, PS log and a tcpdump if possible.

comment:8 Changed 6 years ago by kimquirk

  • Cc dcbw added
  • Keywords blocks:8.2.0 added; blocks:8.2? removed

I just brought up two laptops on joyride 2324 (disguised as 8.2/build 756, which means idle-suspend and cerebro are turned off) and connected both XOs to a WEP AP.

After that they could no longer see each other and they are showing duplicate versions of that access point in the network neighborhood (I really don't think this has anything to do with cloaked APs in the area).

Also there is no sign of my local mesh channels either.

I rebooted and get the same result! Still no sign of the other XO, my mesh channels 1,6, or 11, and there are two APs with the name of the one I'm connected to.

I upgraded this bug to blocks:8.2.0 - if anyone knows who else can help look at this, please speak up.

comment:9 follow-up: Changed 6 years ago by mstone

According to http://wiki.laptop.org/go/Release_Notes/8.2.0#Frame and #6995, it is a Feature that your mesh channel selector appears on the Frame (alongside other devices) instead of on the Neighborhood view. I have closed #8133 on that basis.

The "double APs" issue sounds similar to #4267, which I have reopened.

Finally, there is the "failure to exchange and display presence data", which is the proper subject of this ticket.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 6 years ago by tomeu

  • Cc mtd marco added

Replying to mstone:

According to http://wiki.laptop.org/go/Release_Notes/8.2.0#Frame and #6995, it is a Feature that your mesh channel selector appears on the Frame (alongside other devices) instead of on the Neighborhood view.

Has this really been included in any release?

comment:11 in reply to: ↑ 10 Changed 6 years ago by mtd

Replying to tomeu:

Replying to mstone:

According to http://wiki.laptop.org/go/Release_Notes/8.2.0#Frame and #6995, it is a Feature that your mesh channel selector appears on the Frame (alongside other devices) instead of on the Neighborhood view.

Has this really been included in any release?

No.

Of course, if you're actually connected to the mesh, or a victim of #6944 involving the mesh, you'll see the mesh icon in the frame.

For now I wouldn't worry about "two AP icons in the mesh view" or "both mesh and AP icon in the frame", as those are likely just #6944 - the NM signal handling in Sugar doesn't handle all the signals it should and thus gets itself into a confused state sometimes.

That shouldn't affect collaboration AFAIK.

comment:12 Changed 6 years ago by gdesmott

  • Component changed from presence-service to telepathy-salut

comment:13 Changed 6 years ago by kimquirk

This is a real regression and needs analysis.

comment:14 Changed 6 years ago by kimquirk

  • Resolution set to wontfix
  • Status changed from new to closed

At this point, I believe the problem with not seeing the Mesh icons in the neighborhood was fixed with the latest wireless firmware. The problem of multiple AP is another bug, #7415. There is also a bug related to getting the wrong presense info, #7893.

Closing this bug -- please open a new bug if something else is seen that doesn't match one of the other bugs.

comment:15 Changed 6 years ago by gnu

  • Blocking 7417 added

comment:16 Changed 6 years ago by gnu

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Note that this bug reports failure when two laptops are both connected to an access point, while #7893 is when 5 laptops are in a simple mesh without an access point. I would not assume (at this point, when neither has been diagnosed) that they are both the same problem.

We know the collab is flakey in 8.2.0 candidates, we see reports of it all the time. Why close out valid bug reports that could lead to insight into why it's flakey?

[When I designed a bug reporting system for Cygnus, it refused to allow anyone but the originator of the bug report to close it out. A lot more bugs actually got addressed, than in bug tracking systems where anybody can come in and blast a bug out of existence for their own convenience. Yes, it did involve interacting with the customers to determine whether THEY were satisfied that their problem had actually been addressed. That was a feature, not a bug.]

comment:17 Changed 6 years ago by gdesmott

I think there is good chance than this bug is actually a dup of #7893.

As I said, on #7893 could you retest using Joyride >= 2452 or with 8.2-760 with this package installed: http://koji.fedoraproject.org/koji/getfile?taskID=830361&name=telepathy-salut-0.3.3-8.olpc3.i386.rpm

comment:18 Changed 6 years ago by gdesmott

Would be good to know if someone has still experienced this problem with 8.2-766

comment:19 Changed 6 years ago by gregorio

  • Keywords blocks-:8.2.0 added; blocks:8.2.0 removed
  • Milestone changed from 8.2.0 (was Update.2) to 9.1.0
Note: See TracTickets for help on using tickets.