Opened 6 years ago

Closed 6 years ago

#7979 closed defect (fixed)

can't update most activities over school server squid setup

Reported by: dsd Owned by: cscott
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: upgrade utility Version: not specified
Keywords: blocks?:8.2.0 joyride-2313:+ Cc: martin.langhoff, kimquirk
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

Just filing a ticket to track this issue...

When associated to the school server network where a transparent squid proxy is running, the activity updater only offers 2-4 activities.

Seems to be a problem with the way that the activity updater uses partial HTTP requests and the squid proxy on XS. Scott also reproduced this on an unproxied connection though.

Change History (6)

comment:1 Changed 6 years ago by cscott

I've got a number of packet traces here. On an unproxied connection, the problem seems to be if congestion causes a connection to be closed abruptly; the next pipelined HTTP request causes a BadStatusLine exception to be thrown (when the next response read returns ). With Squid this is 100% reproducible since Squid seems to close then connection w/o warning after two pipelined requests have gone through. Apparently the RFC suggests that clients "should" watch for socket close, regardless of keep-alive status, so it seems that python is at fault even though squid is retarded.

comment:2 Changed 6 years ago by cscott

Turns out to be a bug in python's httplib: http://bugs.python.org/issue3566 combined with some mildly unkosher behavior from Squid (nothing that violates the RFC's MUSTs, though, just a violation of a SHOULD).

Seems like I can workaround it.

comment:3 Changed 6 years ago by dsd

  • Cc martin.langhoff added

comment:4 Changed 6 years ago by dsd

  • Cc kimquirk added
  • Keywords blocks?:8.2.0 added

comment:5 Changed 6 years ago by dsd

  • Keywords joyride-2313:+ added

Works nicely with your workaround in joyride-2313 (sugar-update-control-0.9). shall we close this bug?

comment:6 Changed 6 years ago by mstone

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the prompt fix and testing!

Note: See TracTickets for help on using tickets.