Ticket #7997 (new defect)

Opened 6 years ago

Last modified 6 years ago

need libSDL_Pango.so.1

Reported by: AlbertCahalan Owned by: AlbertCahalan
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: distro Version: not specified
Keywords: relnote Cc:
Action Needed: test in release Verified: no
Deployments affected: Blocked By:
Blocking:

Description

SDL_Pango is required for supporting complicated script languages (Arabic, Thai, etc.) in SDL-based activities.

Tux Paint normally needs it. I can build without it; such a build will be limited to Latin, Greek, Cyrillic, Chinese, Japanese, and Korean.

Change History

Changed 6 years ago by cscott

  • owner set to cscott
  • component changed from not assigned to distro
  • milestone changed from 8.2.0 (was Update.2) to 9.1.0

Changed 6 years ago by gregorio

  • keywords relnote added

Changed 6 years ago by jg

  • next_action changed from never set to communicate
  • milestone changed from 9.1.0 to 8.2.1

Please give us the footprint of the package. No new packages go into the base system without this information....

Changed 6 years ago by cscott

  • next_action changed from communicate to approve for release

SDL_Pango package is 22k. Adding to joyride.

Michael, please consider this for 8.2.

Changed 6 years ago by cscott

pygame-1.8.0-1.olpc3.3 now Requires SDL_Pango. Should be in next joyride, please test.

Changed 6 years ago by cscott

  • milestone changed from 8.2.1 to 8.2.0 (was Update.2)

Changed 6 years ago by mstone

  • next_action changed from approve for release to add to release

Fine by me.

Changed 6 years ago by cscott

  • next_action changed from add to release to test in release

pygame-1.8.0-1.olpc3.3 and SDL_Pango-0.1.2-8 added to stable repo. Should appear in 760 and later. Please test.

Changed 6 years ago by cscott

  • owner changed from cscott to AlbertCahalan

It's been added. Albert -- does it work?

Note: See TracTickets for help on using tickets.