Ticket #8003 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

easily crash Browse and Firefox

Reported by: thomaswamm Owned by: erikos
Priority: high Milestone: 8.2.0 (was Update.2)
Component: browse-activity Version: Development build as of this date
Keywords: Cc:
Action Needed: reproduce Verified: no
Deployments affected: Blocked By:
Blocking: #8265

Description

I did $ sudo olpc-update joyride-2301

I have Q2E12.

I can often crash both Browse and the sugarized Firefox by typing the following into the location box:

originalhooters.com/girls.cfm

Browse usually just freezes the XO, requiring power off/on to recover.

The sugarized Firefox produces a brief console terminal display that says something like "fatal X server error, caught signal 11", then it apparently reboots X-Windows, and Sugar restarts.

The website changes daily, and often has Flash content. It has been an acid test ever since I got my XO. This defect is not new to joyride-2301. A computer should not be crashable by any website. Unsupported features like Flash content should just be ignored without crashing.

Attachments

Xorg.0.log.old (18.3 kB) - added by thomaswamm 6 years ago.
log file from sugarized Firefox crash when trying URL originalhooters.com/girls.cfm
org.laptop.WebActivity-1.log (5.9 kB) - added by thomaswamm 6 years ago.
log file retrieved after Browse crashed from killer URL; gnash is implicated.
org.laptop.FirefoxActivity-1.log (3.3 kB) - added by thomaswamm 6 years ago.
Firefox log following hooters acid test crash.
org.laptop.WebActivity-1.2.log (6.9 kB) - added by thomaswamm 6 years ago.
Browse-96 log following hooters acid test crash (8.2-759).
logs.CSN7500144C.2008-09-15.08-49-40.tar.bz2 (193.2 kB) - added by thomaswamm 6 years ago.
olpc-log (new) after Browse-96 crashed with hooters acid test.
logs.CSN7500144C.2008-09-15.09-06-21.tar.bz2 (194.1 kB) - added by thomaswamm 6 years ago.
olpc-log (new) after Firefox-6 crashed on hooters test. 8.2-760.

Change History

  Changed 6 years ago by thomaswamm

Trying to watch a video at youtube.com will also freeze Browse. Rather than powercycle to recover, I successfully used touchpad and hotcorner to get a frame, then keyboard was usable, then I did ctrl-alt-F1 to get console, autologin as root, # ps -A to find pid of Browse, then # kill [pid] to kill Browse, exit console, then can use Sugar again to view logfile or relaunch Browse (which I am using now as I type this).

Maybe what I am trying to say is that losing control of the XO is very frustrating, and makes diagnosis of crashes difficult. Is there any reliable way to regain control when an Activity seems locked up and keyboard does not respond? Thirty years ago I would just hit ctrl-c to abort a running program and regain control. Much faster than cycling power to reboot.

follow-up: ↓ 3   Changed 6 years ago by cjb

  • keywords Firefox, blocks?:8.2 added; Firefox removed

Albert Cahalan suggested that audio might be causing the crash (as suggested by #7885) and that we could test that somewhat with:

 cd /dev ; ./MAKEDEV audio ; cat urandom >> audio

in reply to: ↑ 2 ; follow-up: ↓ 4   Changed 6 years ago by AlbertCahalan

Replying to cjb:

Albert Cahalan suggested that audio might be causing the crash

I now suspect that this crash is different. The audio-related one causes a complete freeze, even from the Linux console. Here, it seems that some control remains.

Changed 6 years ago by thomaswamm

log file from sugarized Firefox crash when trying URL originalhooters.com/girls.cfm

in reply to: ↑ 3   Changed 6 years ago by thomaswamm

Replying to AlbertCahalan:

Replying to cjb:

Albert Cahalan suggested that audio might be causing the crash

I now suspect that this crash is different. The audio-related one causes a complete freeze, even from the Linux console. Here, it seems that some control remains.

The given website sometimes has audio, and I have not often retained some control, so audio remains a suspect.

Changed 6 years ago by thomaswamm

log file retrieved after Browse crashed from killer URL; gnash is implicated.

  Changed 6 years ago by thomaswamm

Just to be clear, by "sugarized Firefox" I mean the Activity called Firefox 4 in Home List view. Also known perhaps as Firefox-4.xo

  Changed 6 years ago by marco

  • keywords blocks?:8.2.0 added; Browse, Firefox, blocks?:8.2 removed

  Changed 6 years ago by gregorio

  • next_action changed from diagnose to test in build

  Changed 6 years ago by cjb

We think we fixed this with the audio crash firmware fix. Please update build and firmware and retest.

  Changed 6 years ago by erikos

  • next_action changed from test in build to diagnose

is not fixed for me in 2346, the machine froze.

  Changed 6 years ago by thomaswamm

  • blocking 8265 added

  Changed 6 years ago by thomaswamm

Using build 8.2-757, I am still able to crash Browse easily. Firefox.activity seems more resistant now, it just says a plug-in needs to be installed.

Here follows a small portion of a WebActivity log file from a Browse crash (XO locked up) after clicking on a Youtube video. There seems to be some loopiness doing something that repeatedly fails.

I tried to attach the whole log file, but Trac said this: Submission rejected as potential spam (Maximum number of external links per post exceeded, Content contained blacklisted patterns)


dbus.UTF8String('/usr/share/sugar/data/sugar-xo.gtkrc')} /home/olpc/Activities/Browse.activity/downloadmanager.py:275: SyntaxWarning: name '_active_downloads' is used prior to global declaration

global _active_downloads

GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 2: IOR file '/tmp/gconfd-root/lock/ior' not opened successfully, no gconfd located: No such file or directory) 1220380469.863420 WARNING root: No gtk.AccelGroup in the top level window. 1220380469.889413 WARNING root: No gtk.AccelGroup in the top level window. ** (rainbow-daemon:2163): DEBUG: Got client ID "105086865cd9e2d07f122038047511485100000022830001" ** (rainbow-daemon:2163): DEBUG: Setting initial properties ** (rainbow-daemon:2163): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle ** (rainbow-daemon:2163): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself ** (rainbow-daemon:2163): DEBUG: Received SaveComplete message in state save-yourself-done /home/olpc/Activities/Browse.activity/webtoolbar.py:66: GtkWarning: gtk_entry_set_text: assertion `text != NULL' failed

self.props.text = text

NS_PluginInitialize call --------------------------------------------------- xEmbed supported in this browser GTK2 supported in this browser NOTE: NPAPI plugin set GNASHRC to /etc/gnashpluginrc:/home/olpc/isolation/1/uid_to_home_dir/10001/.gnashpluginrc PARAM: type = application/x-shockwave-flash PARAM: src = active_sharing.swf PARAM: style = PARAM: id = active_sharing PARAM: name = active_sharing PARAM: bgcolor = #FFFFFF PARAM: quality = high PARAM: wmode = opaque PARAM: flashvars = t=Videos being watched right now... PARAM: width = 550 PARAM: height = 115 NewStream: The full URL is http://www.youtube.com/active_sharing.swf Closed 30 files. Starting process: /usr/bin/gtk-gnash -x 20972055 -j 786 -k 164 -u http://www.youtube.com/active_sharing.swf -F 35 -U http://www.youtube.com/ -P bgcolor=#FFFFFF -P flashvars=t=Videos being watched right now... -P height=115 -P id=active_sharing -P name=active_sharing -P quality=high -P src=active_sharing.swf -P style= -P type=application/x-shockwave-flash -P width=550 -P wmode=opaque - Forked successfully, child process PID is 2485 RcInitFile: parsing /etc/gnashrc RcInitFile: couldn't open file: /home/olpc/isolation/1/uid_to_home_dir/10001/.gnashrc RcInitFile: parsing /etc/gnashpluginrc RcInitFile: couldn't open file: /home/olpc/isolation/1/uid_to_home_dir/10001/.gnashpluginrc Shutting down Child process exited with status 15 plugin instance destruction shutting down input chan 0xa747c98 NS_PluginInitialize called, but ignored (we already initialized) PARAM: type = application/x-shockwave-flash PARAM: src = active_sharing.swf PARAM: style = PARAM: id = active_sharing PARAM: name = active_sharing PARAM: bgcolor = #FFFFFF PARAM: quality = high PARAM: wmode = opaque PARAM: flashvars = t=Videos being watched right now... PARAM: width = 550 PARAM: height = 115 NewStream: The full URL is http://www.youtube.com/active_sharing.swf Closed 30 files. Starting process: /usr/bin/gtk-gnash -x 20972298 -j 786 -k 164 -u http://www.youtube.com/active_sharing.swf -F 35 -U http://www.youtube.com/ -P bgcolor=#FFFFFF -P flashvars=t=Videos being watched right now... -P height=115 -P id=active_sharing -P name=active_sharing -P quality=high -P src=active_sharing.swf -P style= -P type=application/x-shockwave-flash -P width=550 -P wmode=opaque - Forked successfully, child process PID is 2486 Shutting down Child process exited with status 15 plugin instance destruction shutting down input chan 0xa489250 NS_PluginInitialize call --------------------------------------------------- xEmbed supported in this browser GTK2 supported in this browser NOTE: NPAPI plugin set GNASHRC to /etc/gnashpluginrc:/home/olpc/isolation/1/uid_to_home_dir/10001/.gnashpluginrc:/etc/gnashpluginrc:/home/olpc/isolation/1/uid_to_home_dir/10001/.gnashpluginrc


and more repetitions of the above.

  Changed 6 years ago by cjb

  • keywords blocks:8.2.0 added; blocks?:8.2.0 removed

Greg says this should block, no regressions for Flash.

  Changed 6 years ago by marco

  • next_action changed from diagnose to reproduce

  Changed 6 years ago by marco

  • status changed from new to closed
  • resolution set to duplicate

I think this is another dup of #7419, works fine in latest joyride.

  Changed 6 years ago by thomaswamm

  • status changed from closed to reopened
  • resolution deleted

I did olpc-update 8.2-759.

Browse-96 and Firefox-4 both crash almost instantly after entering

originalhooters.com/girls.cfm

into the location bar. So the #7419 fix is not working for this test case.

The crash behaviour has changed from 757 and 2301. Now it is a very quick crash of only the activity. Sugar stays alive now, which is a vast improvement.

Changed 6 years ago by thomaswamm

Firefox log following hooters acid test crash.

Changed 6 years ago by thomaswamm

Browse-96 log following hooters acid test crash (8.2-759).

  Changed 6 years ago by marco

  • keywords blocks:8.2.0 removed

Sounds like a dup of #8326 now. Resetting the blocks keyword because we added it on the assumption it was Flash regression, which doesn't appear to be at this point.

  Changed 6 years ago by thomaswamm

Browse-96 still crashes in beta build 8.2-760. XO froze quickly, then eventually came alive without Browse. Logs coming.

Changed 6 years ago by thomaswamm

olpc-log (new) after Browse-96 crashed with hooters acid test.

  Changed 6 years ago by thomaswamm

Firefox-6 in 8.2-760 also still crashes. Instant crash, no hanging, no waiting, Firefox just disappears, Home view appears. Maybe a faster alternative to alt-esc to exit Firefox. Logs coming.

Changed 6 years ago by thomaswamm

olpc-log (new) after Firefox-6 crashed on hooters test. 8.2-760.

  Changed 6 years ago by thomaswamm

In beta build 8.2-763, both Browse-98 and Firefox-6 still crash (returning to Sugar Home view) when given url originalhooters.com/girls.cfm

  Changed 6 years ago by erikos

some thoughts have been gone into the issue upstream https://bugzilla.mozilla.org/show_bug.cgi?id=424333

  Changed 4 years ago by godiard

  • status changed from reopened to closed
  • resolution set to fixed

Tested in Browse 108 originalhooters.com/girls.cfm does not crash Browse anymore

Note: See TracTickets for help on using tickets.