Ticket #8029 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

remove activity bundles from library

Reported by: cscott Owned by: mchua
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: library Version: not specified
Keywords: blocks:8.2.0 csafor8.2 Cc: bjordan, skierpage, morgs, mikus@…
Action Needed: finalize Verified: no
Deployments affected: Blocked By:
Blocking: #7423

Description

The 'Activities' page in library-core should be slimmed down: the "built in" activity bundles should be removed, and we should have a better link to the

Error: Failed to load processor Activities
No macro or processor named 'Activities' found

page (which should inherit the slick css from the library's activity page).

Change History

  Changed 6 years ago by mikus

There is a definite problem in that some of the activity bundles in the library are way older than the versions of those activities listed on the wiki Activities page. So if somebody *does* install from the library, they risk lesser function (and perhaps incompatibility with how current builds provide services).

  Changed 6 years ago by sj

  • status changed from new to closed
  • resolution set to fixed

The bundle archive has been replaced by recent software-update functionality, so it isn't being maintained as such -- though individual bundles of someone's favorites are welcome (and cloning the existing bundle doesn't require having any design skills).

The main library is being reduced to the homepage + a customization key of bundles (as with a g1g1 or country activity pack). Any urgent messages should be on that main page.

  Changed 6 years ago by sj

  • status changed from closed to reopened
  • next_action changed from never set to review
  • resolution deleted

check in latest build.

  Changed 6 years ago by sj

  • status changed from reopened to closed
  • resolution set to fixed

  Changed 6 years ago by skierpage

This isn't fixed for me after olpc-update to 8.2-759. I still have activities > finding activities in the main page which still links to an I still have an out-of-date "Activity and Library Bundles" at /usr/share/activities/bundle-archive/ that still offers old activities.

  Changed 6 years ago by skierpage

  • keywords blocks:8.2.0? added
  • status changed from closed to reopened
  • resolution deleted

These are the installable activities that the "Activity and Library Bundles" page in 8.2-759 links to in its bundles/ subdirectory:

  • Analyze-5.xo (in Joyride Software update)
  • Gmail-2.xo
  • Implode-2.xo (now at v4 according to Activities wiki page)
  • LogViewer-6.xo (at v14 now, in Joyride Software update)
  • Poll-16.xo (at v17 now)
  • Simcity-4.xo (in Joyride Software update)
  • SliderPuzzle-3.xo (at v5 now)
  • StopWatchActivity-1.xo
  • Terminal-9.xo (at v 15 now, in Joyride Software update)
  • wikihow-4.xol (not an activity, I'm not sure if it's out-of-date)

In addition, bundle-archive/bundles also contains

  • JigsawPuzzle-1_20071030.xo (at v3 now)

  Changed 6 years ago by mstone

  • cc bjordan, skierpage added
  • keywords blocks:8.2.0 added; blocks:8.2.0? removed
  • next_action changed from review to test in build

Pilgrim commit 58970f29 removes olpc-library-core from joyride per verbal communication with SJ. If it passes test, this commit should be cherry-picked into 8.2 (and is apparently worth 62 MB?).

  Changed 6 years ago by morgs

  • cc morgs added

  Changed 6 years ago by cscott

  • keywords csafor8.2 added

  Changed 6 years ago by cscott

  • next_action changed from test in build to approve for release

Could we do the testing of this so we can move it into a release, please?

  Changed 6 years ago by cscott

  • next_action changed from approve for release to add to release

I'm approving this for stable, untested. Hopefully someone would have shouted by now if the library was broken in joyride.

  Changed 6 years ago by cscott

  • next_action changed from add to release to test in release

Pilgrim patch http://dev.laptop.org/git?p=projects/pilgrim;a=commitdiff;h=dbecdc932f5ebc705cb56a667dd4dccda5594a1c pushed to 8.2 branch. Should be in 8.2 build 760 and later. Please test.

follow-up: ↓ 16   Changed 6 years ago by mstone

  • next_action changed from test in release to finalize

The raw os760.img now contains no library bundles (nor stale .xo's). Installation of library content continues to work on valid library bundles (though it turns out that some of the pre-installed library content like biology-5.xol is not actually formatted correctly). This change does have one unintentional side-effect which is that the default Browse start page has a big empty column on its left side where the full table of contents was formerly displayed. Fortunately, the ToC is successfully filled in when new bundles are installed.

  Changed 6 years ago by mchua

  • owner changed from sj to mchua
  • status changed from reopened to new

taking this ticket; I'll write a test case for it.

  Changed 6 years ago by mikus

  • cc mikus@… added
  • priority changed from normal to blocker

I'm changing this to 'blocker'. My problem is also described by #8493, but the fundamental problem was the removal of activity bundles, without a CLEAR explanation of what the user can do about it.


Installed 762. Launched Browse, which in my setup did not have a connection to the Internet. THERE WAS NO INTUITIVELY-OBVIOUS WAY to get Browse to display information from .xol bundles.


in reply to: ↑ 13   Changed 6 years ago by mikus

Replying to mstone:

This change does have one unintentional side-effect which is that the default Browse start page has a big empty column on its left side where the full table of contents was formerly displayed. Fortunately, the ToC is successfully filled in when new bundles are installed.

To expand upon my problem: It used to be that the user could, by clicking in the Browse left column, see information from installed .xol bundles. Now that column is empty -- and all the clickable links in the Browse center column have internet URLs. Meaning that if Browse does not have internet access, WHAT IS BEING SHOWN (by default) to the user does *NOT* permit the user to "Browse" anything. [What's left is for the user to manually type in the local-URL for the file she wishes to Browse.]


In 762 I tried 'sugar-install-bundle so-and-so.xol' with various .xol bundles. All my attempts failed with error messages claiming unacceptable bundle content. [So much for "the TOC is filled in when new bundles are installed."]

Not a situation I would recommend for kids to cope with.

follow-up: ↓ 18   Changed 6 years ago by mstone

Mikus,

Two comments:

first, the left-hand nav bar is empty because no library bundles are installed. Next, I was able to install several bundles by downloading them from http://wiki.laptop.org/go/Collections with Browse, then running them from the Journal. Third, the activity updater should now be capable of installing library bundles. Fourth, if the bundles are actually broken then they're broken and need to be fixed.

In practice, the manufacturing image we ship will come with some library content pre-installed. When we make a first-draft g1g1 derivative build, I would appreciate your feedback on it since I think it will fix up some of the causes of your frustration in testing a raw OS image.

in reply to: ↑ 17   Changed 6 years ago by mikus

Replying to mstone:

Mikus, Two comments: first, the left-hand nav bar is empty because no library bundles are installed. Next, I was able to install several bundles by downloading them from http://wiki.laptop.org/go/Collections with Browse, then running them from the Journal. Third, the activity updater should now be capable of installing library bundles. Fourth, if the bundles are actually broken then they're broken and need to be fixed. In practice, the manufacturing image we ship will come with some library content pre-installed. When we make a first-draft g1g1 derivative build, I would appreciate your feedback on it since I think it will fix up some of the causes of your frustration in testing a raw OS image.

I try to be correct when I describe a problem. In this case I said that Browse was not connected to the internet, so it did not help when you described downloading bundles with Browse from http://wiki.laptop.org/go/Collections.

Note that http://wiki.laptop.org/go/Collections does not contain pointers to library bundles, but instead contains pointers to wiki pages that contain pointers to library bundles.


I would imagine that sometimes installs (or updates) to 8.2 will need to be done in locations that do not have an internet connection, so I don't think mine was an isolated case.


My basic complaint was that a potential OLPC user would have to dig and dig to come up with the explanation that when a library bundle is not accessible merely through clicks starting on the initial (default) Browse screen, what is needed is to ((1)) fetch (e.g., download) that .xol bundle and ((1a)) put in into the Journal, then ((2)) run that bundle from the Journal.

[For instance, there is the 'sugar-install-bundle' CLI command for installing activity bundles. Why isn't there an equivalent CLI command for installing library bundles ?]

[And with 'sugar-install-bundle' I can install activity bundles into /home/olpc/Activities, WITHOUT taking up "room" in Journal. I don't *want* to use a process for installing library bundles that depends on the continued existence of Journal entries.]


I am unable to use the activity updater at home, because it does not support a way for me to set some environmental variables that are needed for use of my internet connection. [That's why my Browse isn't connected -- I *can* change the Browse settings, but then I have to change them back whenever I leave home. Easier to use Browse-with-internet only when I am not at home.]

So I use the CLI 'sugar-control-panel' command instead (after first exporting the environmental variable settings). It tells me about activity bundles -- but I have NOT noticed it telling me about library bundles.


To repeat, my complaint is not about the raw image not containing library bundles. It is about there not existing a better DESCRIPTION of how, when an XO does not contain library bundles readable without fuss, such library bundles can be installed (even when Browse happens to be not connected to the internet).

  Changed 6 years ago by sj

Mikus,

Library bundles like other bundles can be installed via the software upgrade utility in the (graphical) sugar control panel. sugar-install-bundle should install library bundles as well; this is a bug. Installs and updates in remote locations can use a [[customization key]] which will install any bundles in its customization directory.

follow-up: ↓ 21   Changed 6 years ago by sj

From the past bundle-archive : Poll, Sliderpuzzle, Jigsawpuzzle and stopwatch should all be considered for the latest testing build.

in reply to: ↑ 20 ; follow-up: ↓ 22   Changed 6 years ago by morgs

Replying to sj:

From the past bundle-archive : Poll, Sliderpuzzle, Jigsawpuzzle and stopwatch should all be considered for the latest testing build.

The latest versions, I presume... which reminds me, they probably don't have #8411 license fields. I'll try and do that for the MaMaMedia ones today.

in reply to: ↑ 21   Changed 6 years ago by morgs

Replying to morgs:

Replying to sj:

From the past bundle-archive : Poll, Sliderpuzzle, Jigsawpuzzle and stopwatch should all be considered for the latest testing build.

The latest versions, I presume... which reminds me, they probably don't have #8411 license fields. I'll try and do that for the MaMaMedia ones today.

I've released Poll-18, SliderPuzzle-6 and JigsawPuzzle-4, available on the Activities wiki page, that contain the license field.

  Changed 6 years ago by mchua

Attempting to capture all the expected functionalities from the conversation above here... things that should work:

First, 8.2 should not have library bundles by default (and thus no drop-down sidebar should display in Browse's start page). So here's a test case just for this ticket.

|Test case|

  1. Clean-install an XO with 8.2-763.
  2. Start Browse. The left hand sidebar on the Browse start page should not have any library materials (in fact, there shouldn't be a left-hand sidebar).

  Changed 6 years ago by mchua

Since the build no longer contains default library bundles, this set of features have become important, and their functionality/nonfunctionality has been the topic of a lot of the discussion on this ticket.

* Library bundles should be installable via sugar-install-bundle * Library bundles should be installable via downloading with Browse and starting from the Journal * Library bundles should be installable via Customization Key * When Library bundles are installed, they should show up on the left sidebar of Browse's start page * Regardless of how they are installed, library bundles should be upgradeable with sugar-control-panel's update functionality

Technically, these things aren't related to this ticket (the ticket's just about "hey, take out the default library bundles"), but I will check and see if these work on 763 as well - it sounds like they all should, except for the first one, which is #8652. I'll file bugs if any of the other expected functionalities aren't working - please point me to any relevant tickets that I've missed (I searched but didn't find any).

  Changed 6 years ago by mchua

Grr, mediawiki syntax != trac wiki syntax, and I can't edit my comments... the list, now legible.

  • Library bundles should be installable via sugar-install-bundle
  • Library bundles should be installable via downloading with Browse and starting from the Journal
  • Library bundles should be installable via Customization Key
  • When Library bundles are installed, they should show up on the left sidebar of Browse's start page
  • Regardless of how they are installed, library bundles should be upgradeable with sugar-control-panel's update functionality

  Changed 6 years ago by gregorio

  • status changed from new to closed
  • resolution set to fixed

Closed with no release notes needed. GS

Note: See TracTickets for help on using tickets.