Ticket #8133 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

msh0 interface is not created resulting inability to manipulate the mesh device on the frame.

Reported by: kimquirk Owned by: dwmw2
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: wireless Version: not specified
Keywords: blocks:8.2.0 Cc: marco, mstone, jg, mikus@…, dsd, wmb@…, carrano, jcardona, ashish, ypod@…, meeg
Action Needed: qa signoff Verified: no
Deployments affected: Blocked By:
Blocking:

Description

build 756, based on joyride 2324

When I boot up after cleaninstall, there is no WLAN circle in the frame. In the network neighborhood there are APs but no simple mesh channels. I can click on an AP and connect; but I can't get to simple mesh.

I installed this build on 3 machines: 2 B4 laptops and one MP laptop. Both B4 laptops showed no WLAN connection. The MP laptop showed a connection to Channel 11 (which doesn't make any sense since it should go to channel 1 simple mesh if nothing else is chosen).

In the network neighborhood for all of these, there are infrastructure APs, but no simple mesh channels.

I made this a blocker since it is a serious regression. I don't know if this is wireless issue, a presence kind of issue, or a sugar issue.

We need a diagnosis, work effort and if there is any kind of work around.

Change History

follow-up: ↓ 2   Changed 6 years ago by mstone

  • status changed from new to closed
  • resolution set to invalid

Mesh channel selection is now performed on the Frame, not in the Neighborhood view. See #6995 and http://wiki.laptop.org/go/Release_Notes/8.2.0#Frame.

in reply to: ↑ 1   Changed 6 years ago by mikus

  • cc mikus@… added
  • status changed from closed to reopened
  • resolution deleted

Replying to mstone:

Mesh channel selection is now performed on the Frame, not in the Neighborhood view. See #6995 and http://wiki.laptop.org/go/Release_Notes/8.2.0#Frame.


This is a VERY real problem I see on 756 -- "can't get to simple mesh". Saying that ticket #8133 is "invalid" will not make this problem go away.

What is happening to me is that the XO sees APs (to which I do not wish to connect <or can not, even if I try to>), but there is NO "Mesh" icon, neither in Neighborhood view nor in the Frame.

'ifconfig' is not showing me a mesh. How am I supposed to do "Mesh selection" when there is no mesh icon ???

  Changed 6 years ago by mstone

  • cc dsd added
  • summary changed from No way to get to simple mesh channels to msh0 interface is not created resulting inability to manipulate the mesh device on the frame.

Fine, but what matters is the root cause of the issue and its proximate symptoms; not its ultimate symptoms.

  Changed 6 years ago by mstone

  • cc wmb@…, carrano, jcardona, ashish added

Both the libertas firmware and OFW were updated in joyride-2323 (and 8.2-755). We should start our bisection there.

  Changed 6 years ago by ypod

  • cc ypod@… added

  Changed 6 years ago by carrano

joyride-2324 has an experimental firmware version (0.0.0.p18) designed to help debug #7973.

Moving back to the 22.p17 firmware release seems to fix this bug.

I'll try to gather more information.

Ashish,

Would you take a look at it too?

  Changed 6 years ago by carrano

This is what we want to see (and we do with 22.p17):

[   34.484362] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   36.116468] ADDRCONF(NETDEV_CHANGE): msh0: link becomes ready
[   37.652023] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

This is not what we want (and is what we get with 0.p18):

[   45.752281] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  113.652785] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

  Changed 6 years ago by carrano

So, this can be explained by the fact that the msh0 is not being started because of the version this firmware advertises (new code in the driver checks that).

As soon as it's released as 22.p18 we will be able to move forward with the tests (and close this ticket).

  Changed 6 years ago by meeg

  • cc meeg added

  Changed 6 years ago by cscott

22.p18 is in joyride and 8.2-757. Test away.

  Changed 6 years ago by cjb

  • next_action changed from diagnose to qa signoff

  Changed 6 years ago by jcardona

This works for me with joyride 2346.

  Changed 6 years ago by kimquirk

  • status changed from reopened to closed
  • resolution set to fixed

Fixed with new firmware.

  Changed 6 years ago by mikus

For what it's worth :

In Joyride 2595 there are no "mesh icons" in Neighborhood View. Nor can the gray circles in the bottom edge of Frame be clicked on to activate mesh. The result is that F10 currently exhibits exactly the user (NON)input situation that this ticket initially described.

Note: See TracTickets for help on using tickets.