Opened 6 years ago

Closed 2 years ago

#8247 closed enhancement (fixed)

speex files cannot be played reliably, if at all.

Reported by: sj Owned by: erikos
Priority: low Milestone: 9.1.0-cancelled
Component: browse-activity Version: not specified
Keywords: cjbfor9.1.0 Cc: humitos
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

See also #3839 (in browse), #4827, #5353, and #6261

Browse does not even admit to knowing how to handle speex, which gstraeamer should support (#3839). Etoys claims to handle it, but will play back at inferior quality somehow (compare on standard feora and on etoys in 757), and etoys hangs on switching windows and returning to the etoys instance playing a speex file.

Watch & Listen should also supprort speex, but does not.

The Journal does not recognize speex extensions as audio files, for sorting and searching.

most of all, for 8.2, we should check that none of these failures aredue to lacking some core component that cannot be added via an activity update.

Change History (5)

comment:1 Changed 6 years ago by sj

  • Component changed from not assigned to browse-activity
  • Owner set to erikos
  • Priority changed from normal to high

This is really a bug for gstreamer, or for 'audio format support' in general, not for browse... there should be catchall 'audio' and 'video' components for trac.

comment:2 Changed 6 years ago by gregorio

  • Milestone changed from Not Triaged to 8.2.1
  • Type changed from defect to enhancement

comment:3 Changed 6 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

comment:4 Changed 2 years ago by humitos

  • Cc humitos added
  • Priority changed from high to low

There are some samples here:

I can play it with

 gst-launch playbin uri="file:///home/olpc/male_speex_8.wav"

but Browse is not using GStreamer, I think.

comment:5 Changed 2 years ago by humitos

  • Resolution set to fixed
  • Status changed from new to closed

After restarting Browse, I was able to reproduce this file inside it. I think there was some problem because I was testing Record and Browse together because of another issue.

Note: See TracTickets for help on using tickets.