Opened 6 years ago

Closed 6 years ago

#8395 closed defect (fixed)

yum 3.2.19 performance regression

Reported by: mikus Owned by: mchua
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: distro Version: Development build as of this date
Keywords: blocks:8.2.0 Cc: mikus@…
Blocked By: Blocking:
Deployments affected: Action Needed: test in release
Verified: no

Description

I have a wired connection. After installing Joyride 2414, I tried to use yum. After the message 'Excluding Packages from Fedora 9 - i386', NOTHING further happens (yum just sits there). [I was able to run yum on another XO (with Joyride 2411) just now, so it is *not* at the Fedora end.]

Attachments (2)

logs.CSN74804910.2008-09-10.07-21-45.tar.bz2 (67.0 KB) - added by mikus 6 years ago.
olpc-log taken on another Terminal while yum was "stuck"
stuckyum.tar.bz2 (62.4 KB) - added by mikus 6 years ago.
2418 - olpc-dump while yum stuck

Download all attachments as: .zip

Change History (15)

Changed 6 years ago by mikus

olpc-log taken on another Terminal while yum was "stuck"

comment:1 Changed 6 years ago by mstone

  • Action Needed changed from never set to package
  • Component changed from not assigned to distro
  • Keywords blocks:8.2.0 added
  • Milestone changed from Not Triaged to 8.2.0 (was Update.2)
  • Owner set to cscott

Mikus -- we'll fix this if we can. Yum should work on 8.2.0 if at all possible.

comment:2 Changed 6 years ago by mikus

Tried it again on Joyride 2418. Same result. [The message after which yum got "stuck" was now 'Excluding Packages from Fedora 9 - i386 - Updates Newkey'.]

Changed 6 years ago by mikus

2418 - olpc-dump while yum stuck

comment:3 Changed 6 years ago by mikus

After the "built-in" yum did not work for me on 2418, I manually reinstalled yum-3.2.17-2.fc9.noarch there. Then yum worked as it should.

comment:4 follow-up: Changed 6 years ago by cscott

This is now an upstream yum bug:

https://bugzilla.redhat.com/show_bug.cgi?id=461995

https://lists.dulug.duke.edu/pipermail/yum/2008-September/010987.html

I've reverted joyride to yum-3.2.17-2.fc9.noarch as a workaround for now; upstream informs me that nothing in the 3.2.19 release is needed to cope with the fedora key rotation.

comment:5 Changed 6 years ago by cscott

  • Summary changed from yum does not work for me on 2414 to yum 3.2.19 performance regression

Retitling bug; upstream would like us to try a patch to fix the regression.

comment:6 in reply to: ↑ 4 Changed 6 years ago by mikus

Replying to cscott:

I've reverted joyride to yum-3.2.17-2.fc9.noarch as a workaround for now

I don't have any objection to the workaround. I *do* like to fetch the package which includes 'yumdownloader' - and that package (with the "repository search list" as used by Joyride 2424) has a dependency on yum-3.2.19-3 -- which yum for some reason couldn't resolve, and therefore terminated that fetch attempt.

comment:7 follow-up: Changed 6 years ago by cscott

  • Action Needed changed from package to test in build

Believed fixed in yum-3.2.19-3.1, in joyride-2441 and later.

comment:8 in reply to: ↑ 7 Changed 6 years ago by mikus

Replying to cscott:

Believed fixed in yum-3.2.19-3.1, in joyride-2441 and later.


Works for me in joyride 2442.

For me, though the new yum was present, joyride 2441 still gave some sort of trouble (I forget exactly what).

comment:9 Changed 6 years ago by cscott

  • Action Needed changed from test in build to approve for release

hm. record any trouble here if you see it again. I'll get this yum moved into the stable build, and hopefully that will solve our yum troubles.

comment:10 Changed 6 years ago by mstone

  • Action Needed changed from approve for release to add to release

Approved.

comment:11 Changed 6 years ago by cscott

  • Action Needed changed from add to release to test in release

Please test build 761 resulting from build-repo commit c5fe8f51.

comment:12 Changed 6 years ago by mchua

  • Owner changed from cscott to mchua

assigning to myself to test in 763.

comment:13 Changed 6 years ago by mchua

  • Resolution set to fixed
  • Status changed from new to closed

verified, tested, and closed in 765.

Note: See TracTickets for help on using tickets.