Ticket #8433 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Recently, yum install fails during the checking of package GPG keys.

Reported by: mikus Owned by: cscott
Priority: high Milestone: Not Triaged
Component: not assigned Version: not specified
Keywords: polish:8.2.0 Cc: mikus@…, garycmartin, dgilmore, mstone
Action Needed: test in release Verified: no
Deployments affected: Blocked By:
Blocking:

Description

This week on Joyride (but using yum-3.2.17-2) I've been unable to install anything with 'yum install'. Instead of giving me the "Complete!" message, it tells me "Public key for <package> is not installed". I have to add '--nogpgcheck' to the command for it to complete the install. [This seems to occur for *every* package I've tried to download with yum.]

Attachments

screen Download (80.5 KB) - added by mikus 6 years ago.
screen capture of Terminal when trying to use 'yum install vsftpd'

Change History

Changed 6 years ago by mikus

screen capture of Terminal when trying to use 'yum install vsftpd'

follow-up: ↓ 2   Changed 6 years ago by cscott

  • owner set to cscott
  • next_action changed from never set to test in build

Should be fixed by the inclusion of fedora-release 9-5.transition.1, which happened in joyride-2416. Of course, upgrading to the 'latest' yum caused a peformance regression (#8395), so you won't be able to tell that it works until that's fixed.

in reply to: ↑ 1   Changed 6 years ago by mikus

Replying to cscott:

Should be fixed by the inclusion of fedora-release 9-5.transition.1, which happened in joyride-2416.

For what it's worth, I encountered this same 'key not installed' with yum when I installed joyride-2418 (after making only ONE change to 2418 - downleveling yum to version 3.2.17-2).


It was recommended that I issue the 'yum install' twice. Having just done a fresh build install, I tried that - and it worked. But I don't want to get into the habit of "run the SAME command again" if I didn't like the results of the command the first time.

  Changed 6 years ago by gregorio

  • keywords polish:8.2.0 added

Hi Guys,

I think Yum is very important. Not sure if I can delay the release for it but we want this to work so please fix it ASAP if you can.

Thanks,

Greg S

  Changed 6 years ago by cscott

  • next_action changed from test in build to approve for release

fedora-release 9-5.transition.1 to 8.2. No retry seems to be necessary any more.

  Changed 6 years ago by garycmartin

  • cc garycmartin added

Hmmm, after several attempts was not able to install "git" onto an XO joyride-2423 here via yum (planning to package a new version of Moon over the weekend, and need XO tools to do all the manifest stuff correctly). Then tried "yum install patch" and it worked, so tried "git" again, failing with the below error. Then tried yum installing "vim" and it worked fine. Gave "yum install git" one more try and this time it installed successfully! I thought package dependencies were meant to avoid such things (I'm used to working with aptitude and/or apt-get from the deb side of things)?

--- snip ---
Total size: 18 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Importing GPG key 0x4F2A6FD2 "Fedora Project <fedora@redhat.com>" from
/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-i386
Is this ok [y/N]: y
Public key for git-1.5.5.1-1.fc9.i386.rpm is not installed

  Changed 6 years ago by mikus

Installed 2424. Wanted to add several rpms. The yum install failed with the 'Public key ... is not installed' message. Repeated the yum command, *again* got the failure - but this time telling me the name of a different package. Got tired of the run-around. Issued yum with '--nogpgcheck'.

  Changed 6 years ago by cscott

  • next_action changed from approve for release to diagnose

fedora-release 9-5.transition.1 has been added to the stable repository:  http://mock.laptop.org/gitweb/gitweb.cgi?p=repos;a=commitdiff;h=94d60a3cc2643606f28d9c9a9f562020924c0537

This should be in 8.2 build 760 and later. It seems like this is not sufficient to fix the 'public key is not installed messages'. I'm out of ideas, guys: please help me figure out what to do to fix this. I suggest asking the fedora folks for help.

  Changed 6 years ago by cscott

  • cc dgilmore, mstone added

 https://fedoraproject.org/wiki/Enabling_new_signing_key seems relevant, but I'm not sure exactly what to do about it yet. We pull directly from koji: are we getting the old packages or the new signed packages? Help wanted!

  Changed 6 years ago by mikus

Just had this same problem with Joyride-2436. So whatever software fixes are included in 2436, this problem is still there.

follow-up: ↓ 11   Changed 6 years ago by cscott

OK, how about joyride-2441 (and later)? I can't reproduce the problems with yum-3.2.19-3.1. mikus? garycmartin?

in reply to: ↑ 10   Changed 6 years ago by mikus

Replying to cscott:

OK, how about joyride-2441 (and later)? I can't reproduce the problems with yum-3.2.19-3.1. mikus? garycmartin?

I'll give it a provisional o.k.

Have not had yum recently fail for me in the way described by this ticket, even when using yum-3.2.19-3.1. Have had yum ask me for confirmation of downloading a new GPG key - but then the package install was completed correctly.

[Back when this problem came up, and I had specified more than one package, yum would fail on the first package even when it had prompted me to allow installing the key for it. When I repeated the command, yum would then fail likewise after having prompted me to allow installing the key for the second package. Now, with joyride 2442, yum prompts me once even when I have specified more than one package - and with joyride 2442 yum then goes on to install both packages.]

  Changed 6 years ago by cscott

  • next_action changed from diagnose to approve for release

yum-3.2.19-3.1 to stable build.

  Changed 6 years ago by garycmartin

Tested on XO running joyride-2444. Looks good to me, no failures while trying to instal git, patch, and vim.

  Changed 6 years ago by mstone

  • next_action changed from approve for release to add to release

Approved.

  Changed 6 years ago by cscott

  • next_action changed from add to release to test in release

Please test build 761 resulting from build-repo commit  c5fe8f51.

  Changed 6 years ago by cscott

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.