Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8490 closed defect (fixed)

screen pulses coming out of standby

Reported by: skierpage Owned by: cjb
Priority: normal Milestone: 9.1.0-cancelled
Component: power manager (OHM) Version: not specified
Keywords: cjbfor9.1.0 Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: test in release
Verified: no

Description

(adapted from e-mail "XO screen pulses after "standby", OOM afterwards" sent to devel list)

Twice with 8.2-759 my G1G1 machine has had the screen flash on and off coming out of a "standby" (screen off) state. The second time seemed a memory pressure state that didn't ease until I rebooted.

The pulsings happened after I left my XO disconnected from power and it went dead, so much so that I had to do a http://wiki.laptop.org/go/XO_Full_Reset. But the laptop was running fine before the screen went off. Both times:

  • Screen is off, but IIRC the green power light is on.
  • I press the power on button, nothing happens. So press it some more, also press some random keyboard keys.
  • Then the screen flashes on for less than a second, goes blank for about 40 seconds, flashes on, goes blank for 40 seconds... The first time the screen flashed at least 10 times before staying on, this time it flashed at least three times.

Both times it feels as if the laptop is so sluggish that it's queued up my power button presses.

The second time the laptop seems extremely slow afterwards. I ran various memory commands as I killed activities, restarted X and sugar, then rebooted, see http://wiki.laptop.org/go/User:Skierpage/out-of-memory

Change History (7)

comment:1 Changed 6 years ago by cjb

This is probably #8301, please re-test with 8.2-760.

comment:2 Changed 6 years ago by pgf

for the record, a laptop of mine got into a similar seeming state twice:
it was clearly in a mode where it kind of wanted
to wake up, but then immediately went back to sleep. i describe it
this way because the second time it happened, i was eventually able to
get it to stay "awake" by very quickly hitting a key during the brief
interval that the screen was on. i recall thinking that the idle timeout
hadn't been reset by my hitting the power button, or something like
that.

comment:3 Changed 6 years ago by kimquirk

  • Keywords relnote added
  • Milestone changed from Not Triaged to 8.2.1

comment:4 Changed 6 years ago by kimquirk

We want to release note this for 8.2.0, so if someone can figure out under what conditions it happens through systematic testing, that would be helpful...

comment:5 Changed 6 years ago by cscott

  • Action Needed changed from never set to test in release
  • Keywords relnote removed

This is believed fixed. Please reopen if this appears in any build after 760.

comment:6 Changed 6 years ago by cscott

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 6 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

Note: See TracTickets for help on using tickets.