Opened 6 years ago

Closed 5 years ago

#8493 closed defect (fixed)

There is no content (library browse) on latest build

Reported by: kimquirk Owned by: cscott
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: library Version: not specified
Keywords: blocks:8.2.0 Cc: mikus@…, m_stone, gregorio
Blocked By: #8106 Blocking:
Deployments affected: Action Needed: design
Verified: no

Description

build 8.2-760

After cleaninstall or olpc-update to this latest build, when you go to browse there is nothing on the left hand side of the browser window. This used to be where the books and content were.

Change History (7)

comment:1 Changed 6 years ago by mstone

  • Action Needed changed from never set to design

This is expected based on #8029. Either install a non-raw OS, use a customization stick, or get cscott to make the activity updater install some library content.

comment:2 Changed 6 years ago by sj

  • Owner changed from sj to cscott

while this is expected from 8029, a specific concern is that olpc-updating from an older build removes the defualt library (just as an earlier flag day olpc-update removed activities...)

I think the priority here is ensuring that the g1g1 build (for instance) will properly include both collections and activities through the bundle-installation process.

comment:3 Changed 6 years ago by kimquirk

  • Keywords blocks:8.2.0 added

Scott - can you tell us if the activity updater was designed to work for content. If so, then perhaps there is a bug. If not, then perhaps this is a future feature.

comment:4 Changed 6 years ago by cscott

  • Blocked By 8106 added

comment:5 Changed 6 years ago by mikus

  • Cc mikus@… added

Added my explanation of a "critical" problem to #8029. Basically, if 8.2 is installed from the customization sticks available today, but the system is not connected to the internet, then the user is more or less out of luck in trying to access information provided through .xol bundles.

comment:6 Changed 6 years ago by kimquirk

  • Cc m_stone gregorio added

For the issue where you cleaninstall the latest build or if you use olpc-update to get the latest build, the result is the same, the content or collection info does not update.

The activity updater gets the activities and installs them, but it doesn't get the collections or content. The page where the content is being pulled from is: http://wiki.laptop.org/go/Activities/G1G1/8.2.0

I think this needs to be fixed for 8.2. IF the problem is in the wiki page, we can release the xo build.

comment:7 Changed 5 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

as of 8.2.0, the activity updater does handle content bundles

Note: See TracTickets for help on using tickets.