Ticket #8497 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Browse/gnash can't run a Flash .swf URL

Reported by: skierpage RussNelson Owned by: erikos
Priority: high Milestone: 9.1.0-cancelled
Component: browse-activity Version: not specified
Keywords: relnote polish:8.2.0 cjbfor9.1.0 Cc: gregorio
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking: #7382, #7421

Description

In Browse 96 on 8.2-760:

You should be able to load a .swf URl "standalone" in the browser. Here's a simple, tiny one (from the Flash about page ):

http://www.adobe.com/swf/software/flash/about/flashAbout_info_small.swf

If you load this URL in Browse, you see the initial Flash [[Click to play]][X] control UI, so I assume Browse correctly loads the gnash plug-in to handle the swf mime type. But if you click to play, the windows blanks and nothing appears. I didn't see any errors in the WebActivity log.

Since rendering a swf and the surrounding Web page consumes more memory, and since swfs on their own usually resize nicely to screen, being able to run a "naked" .swf URL would be nice.

I don't know if this is a problem in gnash, libxulrunner, or Browse.

Change History

Changed 6 years ago by gregorio

  • cc gregorio added
  • keywords relnote blocks:8.2.0 added
  • priority changed from normal to high
  • milestone changed from Not Triaged to 8.2.0 (was Update.2)

Hi S.

I'm checking if this is a regression (aka worked in 70x). If so I say we make it a blocker.

We'll see if that holds...

Thanks,

Greg S

Changed 6 years ago by gregorio

  • keywords blocks:8.2.0 removed
  • milestone changed from 8.2.0 (was Update.2) to 8.2.1

I tested this with 708 and got the same results :-(

Sure would be nice to fix this for all the reasons mentioned.

However, our agreement on 8.2 is that it must not be worse so I need to downgrade this one to 8.2.1 and I'll put it in the 8.2 release notes.

Thanks,

Greg S

Changed 6 years ago by skierpage

As a workaround you can enter gnash http://some/url.swf in a terminal.

Changed 6 years ago by cscott

  • keywords polish:8.2.0 added
  • blocking 7382, 7421 added

Changed 6 years ago by gregorio

Hi S,

Thanks a lot for the tip!

Good to have a workaround, but if it works at the CLI why doesn't work the GUI!

Simon,

Can you tell me how hard this is to fix? What else would you have to defer to look at this?

Flash is important and this problem makes it look like we support a lot less Flash than we really do.

Thanks,

Greg S

Changed 6 years ago by RussNelson

What version of gnash are you running? The current source control version works for at least some flash games.

Not for this:

> http://www.ferryhalim.com/orisinal/g3/00sunny.swf

Doesn't work on my Linux Adobe flash7 either. I suspect that something in that swf requires flash version >7.

This works: http://www.ferryhalim.com/orisinal/g2/applegame.htm as does this when run from the command line OR directly as a URL: http://www.ferryhalim.com/orisinal/g2/00applegame.swf

Changed 6 years ago by gregorio

  • reporter changed from skierpage to skierpage RussNelson

Hi Russ,

Thanks for the info. I entered this URL http://www.ferryhalim.com/orisinal/g2/00applegame.swf in my browse running build 8.2-759 and it still did not play the flash animation.

Are you saying that played for you?

Thanks,

Greg S

Changed 5 years ago by mstone-xmlrpc

  • keywords cjbfor9.1.0 added
  • milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

Changed 4 years ago by godiard

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.