Opened 6 years ago

Last modified 6 years ago

#8504 new defect

no sound from Flash .swf files in Gnash

Reported by: skierpage Owned by: rsavoye
Priority: high Milestone: 9.1.0-cancelled
Component: gnash-plugin Version: Development build as of this date
Keywords: blocks-:8.2.0 cjbfor9.1.0 Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

I don't hear sounds from Flash movies in Browse 96 in 8.2-760.

E.g. the top left game at http://www.ferryhalim.com/orisinal/ is currently Sunny Day Sky, , no sound.

I found a small sample swf with sound in the gnash distribution, here it is: http://www.skierpage.com/olpc/flash_tests/
Currently a "naked" swf doesn't load in Browse (bug #8497), so click embed_car_smash.html

You can also run gnash standalone from Terminal:

gnash http://www.skierpage.com/olpc/flash_tests/car_smash.swf

and that has no sound either. So I'm assigning to component gnash-plugin rather than browse-activity.

strace shows gnash attempting to load various GStreamer and alsa files.

Attachments (1)

browse_gnash_sound2.tar.gz (42.9 KB) - added by skierpage 6 years ago.
strace -ff result after using Forward in Browse to return to the web page

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by skierpage

strace -ff result after using Forward in Browse to return to the web page

comment:1 Changed 6 years ago by gregorio

  • Keywords blocks-:8.2.0 added; blocks:8.2.0? removed
  • Milestone changed from Not Triaged to 8.2.1
  • Priority changed from normal to high

Didn't play sound in 708 either!

I really wish we could fix flash at least this one and 8497.

Anyway, not regression to not blocker for now.

Thanks,

Greg S

comment:2 Changed 6 years ago by object404

Hi. 766 on its own comes with a Gnash binary/plugin that isn't compiled with sound. This was the same with Build 656 and Build 711 afaik.

So this is not a "bug" per se with the Gnash that comes pre-installed with the XO.

see:
http://wiki.laptop.org/go/Restricted_Formats on this.

However, I'm having trouble myself customizing and doing the necessary things to modify/activate sound/mp3 playback with the Gnash on the XO as there's very little documentation on it.

I tried adding the livna repository and then installing gstreamer-ffmpeg via yum, but I ran into problems.

Leads would be great.

-Naz

comment:3 Changed 6 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

comment:4 Changed 6 years ago by skierpage

If you add MP3 codec to GStreamer (see Bug #8982 comment #27, or http://wiki.laptop.org/go/Fluendo_mp3_decoder ), then sound in the sample swf plays in Gnash!

The Orisinal games I tried are still silent, and even more sluggish.

comment:5 Changed 6 years ago by rsavoye

It you are still shipping the ancient 0.8.2 build of Gnash, don't expect anything to work well. Upgrading to a new release (0.8.5 is coming out any day now) would help your problem a lot. These URLs work fine for me with Gnash pre-release. You can try the pre-release as well yourself:
http://www.getgnash.org/packages/snapshots/fedora/gnash-plugin-prerelease_20090227-1.i386.rpm
http://www.getgnash.org/packages/snapshots/fedora/gnash-prerelease_20090227-1.i386.rpm. These packages are built with ffmpeg support as a dynamic library, so grab it from livna or rpmfusion. The Gstreamer implementation is so out of whack it's useless for Gnash on the XO, so I used ffmpeg. which works just fine, YouTube included.

Note: See TracTickets for help on using tickets.