Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#8632 closed defect (wontfix)

EC does not start up on low battery

Reported by: sj Owned by: rsmith
Priority: blocker Milestone:
Component: embedded controller Version: not specified
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: diagnose
Verified: no

Description

I couldn't find the ticket for this, so here goes (please dup as needed) : when I lose all power to an XO, sometimes to recharge that battery I need to take the battery out, power on the XO, and put it back in once powered on; it won't turn on and charge with the battery in.

What's the status of this? I haven't seen it since my last flight with an XO, but have seen it fairly regularly over the months.

Change History (12)

comment:1 follow-up: Changed 6 years ago by cjb

  • Component changed from power manager (OHM) to embedded controller
  • Owner changed from cjb to rsmith

This doesn't have anything to do with userspace. Over to Richard.

comment:2 in reply to: ↑ 1 Changed 6 years ago by rsmith

Replying to cjb:

This doesn't have anything to do with userspace. Over to Richard.

The description suggests that the voltage on the battery is going so low that the EC is failing to run. This should not happen under normal use. Only after a long storage period.

Some tests: Does EC work at all when this happens? If you plug up power are you able to boot the XO and use it normally or do you have to remove the battery first?

Next time it happens run olpc-pwr-log before you re-insert the battery let it charge till its full and send me the log.

comment:3 follow-up: Changed 6 years ago by mstone-xmlrpc

  • Milestone changed from Not Triaged to 8.2.1

changed by irc user cjb:

No time to fix this for 8.2.0. I've seen it too, though, so it's a legitimate bug.

comment:4 Changed 6 years ago by cjb

  • Keywords relnote added

comment:5 in reply to: ↑ 3 Changed 6 years ago by rsmith

Replying to mstone-xmlrpc:

changed by irc user cjb:

No time to fix this for 8.2.0. I've seen it too, though, so it's a legitimate bug.

If its a low voltage crash then its a won't fix. We don't put a proper reset supervisor on the PCB cause of cost.

comment:6 Changed 6 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

comment:7 Changed 5 years ago by rsmith

  • Keywords relnote cjbfor9.1.0 removed
  • Milestone changed from 9.1.0 to 1.5-F11
  • Priority changed from normal to blocker
  • Summary changed from old power issue : when power runs down, recharging sometimes requires fiddling with battery to EC does not start up on low battery

This problem seems to exist on Gen 1.5 as well. If the battery voltage is very low then the EC does not start up. Currently working with Quanta to figure out where the problem is.

comment:8 follow-up: Changed 5 years ago by RafaelOrtiz

confirmed in one machine that got totally discharged, then when re-plugged to the DC adapter, it seems that the battery could not be recharged, watch-battery gets stalled at 0.00A of charging current.

comment:9 in reply to: ↑ 8 Changed 5 years ago by rsmith

Replying to RafaelOrtiz:

confirmed in one machine that got totally discharged, then when re-plugged to the DC adapter, it seems that the battery could not be recharged, watch-battery gets stalled at 0.00A of charging current.

Thats a different bug. Thats #9530 EC does not sense battery. Which I just closed cause it seems to be fixed in my tree. Will be in then next firmware after q3a14.

With this bug you can't even turn the XO on because the EC handles all the button presses. So no EC == no buttons == no startup.

comment:10 Changed 5 years ago by Quozl

  • Action Needed changed from never set to diagnose

Review. On XO-1, agreed wontfix. On XO-1.5, has there been any progress? Do we have an EC reset supervisor on the PCB?

comment:11 Changed 5 years ago by wad

  • Resolution set to wontfix
  • Status changed from new to closed

The problem on XO-1.5 turned out to be that certain EC pins are test pins and should not be asserted when the EC is reset. It turns out that we have been using these pins for input signals in both the XO-1 and XO-1.5 early prototypes.

By XO-1.5 C build, we should have fixed the problem.

On XO-1, there are known conditions that will prevent the EC from booting, such as the laptop being in tablet mode.

comment:12 Changed 5 years ago by anonymous

  • Milestone 1.5-software deleted

Milestone 1.5-software deleted

Note: See TracTickets for help on using tickets.