Opened 7 years ago

Closed 7 years ago

Last modified 4 months ago

#8681 closed defect (duplicate)

Software update aborts/hangs when there is no Activities directory

Reported by: tvoverbeek Owned by: cscott
Priority: blocker Milestone:
Component: upgrade utility Version: not specified
Keywords: blocks-:8.2.0 cjbfor9.1.0 Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no


When trying to run software update after my Activities directory disappeared (see #8674) it kept hanging on trying to find the groups.
Looking at the log a thread aborted because it could not write to /home/olpc/Activities/.groups, which was true since there was no Activities directory.
Software update should be more robust against these types of failures. Also we need better user feedback when a thread aborts (the software update panel stayed up without any messages). Same situation when an activity aborts and its icon keeps pulsing.

Change History (4)

comment:1 Changed 7 years ago by mstone-xmlrpc

  • Keywords blocks-:8.2.0 added; blocks?:8.2.0 removed
  • Milestone changed from Not Triaged to 8.2.1

changed by irc user cjb:

comment:2 Changed 7 years ago by cscott

  • Resolution set to duplicate
  • Status changed from new to closed

Regression/dup of #7845.

comment:3 Changed 7 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

comment:4 Changed 4 months ago by Quozl

  • Milestone 9.1.0-cancelled deleted

Milestone 9.1.0-cancelled deleted

Note: See TracTickets for help on using tickets.