Ticket #8916 (closed defect: invalid)

Opened 6 years ago

Last modified 3 years ago

Extreme Power Management doesn't unload USB for fast resumes

Reported by: gnu Owned by: cjb
Priority: normal Milestone: 9.1.0-cancelled
Component: power manager (OHM) Version: not specified
Keywords: cjbfor9.1.0 Cc: mikus@…
Action Needed: reproduce Verified: no
Deployments affected: Blocked By:
Blocking:

Description

The "Extreme Power Management" setting is supposed to disable both the WiFi and the USB ports, resulting in resume happening more than twice as fast.

It never unloads these modules. "lsmod" after checking extreme power management (and after the WiFi lights go out) still shows usbcore and usb8xxx and libertas modules, as well as the ehci and ohci_hcd modules.

Thus resume never speeds up.

This is in 8.2.0 (foolishly, there's no setting for 8.2.0 in the Version field).

Change History

Changed 6 years ago by gnu

I tried manually doing "rmmod"s and was able to remove all but "usbcore", which has a reference count of 1, shows no modules depending on it, and which won't remove. I'm not sure why not.

Resume seems to be taking only half a second, but due to broken or confusing kernel timestamp logging (plus a pile of cafe1000-ccic error messages during resume), it's hard to tell.

Changed 6 years ago by mikus

  • cc mikus@… added

I'm not sure of what the "summary description" of #8916 is intended to convey.

If you want 'resume' to run quickly, such that non-USB devices are put into service immediately, while USB devices receive "lazy activation" -- then I have no problem with #8916.

HOWEVER, all my XOs have USB devices attached. If by #8916 you mean that USB-related modules need to "disappear" from the kernel -- to me that would be not acceptable.

Instead of making USB-related modules "disappear" automatically, let me suggest splitting "Extreme Power Management" (in the Control Panel) into two checkmarks. One of them says "please attempt USB resume, even if that slows down recovery from suspend". The other says "do not attempt USB resume after having suspended". That way it becomes the user's choice -- whether to favor speed or to favor function.

Changed 6 years ago by mstone-xmlrpc

  • keywords cjbfor9.1.0 added
  • milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

Changed 3 years ago by greenfeld

  • status changed from new to closed
  • resolution set to invalid

Ohmd has been replaced by powerd, and the extreme power management toggle is not supported by powerd (although it has recently snuck back into sugar (#10753).

Note: See TracTickets for help on using tickets.