Ticket #9044 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

software updater needs spanish translation

Reported by: kimquirk Owned by: cscott
Priority: high Milestone: 8.2.1
Component: sugar Version: not specified
Keywords: cjbfor9.1.0 8.2.1:+ Cc: sayamindu, cscott, cjl
Action Needed: finalize Verified: no
Deployments affected: Uruguay Blocked By: #8788
Blocking:

Description

Uruguay request.

Change History

Changed 6 years ago by kimquirk

  • owner changed from marco to sayamindu

Changed 6 years ago by sayamindu

  • blockedby 8788 added

We have the translations, but those won't appear unless #8788 gets fixed :-(

Changed 6 years ago by mchua

|Test case|

On an XO running the 8.2.1 release candidate in question...

  1. Use the graphical sugar-control-panel UI to set your language to es.
  2. Reboot Sugar.
  3. Go to the software updater in the graphical sugar-control-panel, and run an update.

Test passes if all text appears in Spanish.

Changed 6 years ago by cjb

#8788 is fixed in HEAD now, see that bug for details.

Changed 6 years ago by cscott

A .pot file and pootle component also need to be generated, as well as actually translating the text and releasing a version with the translations.

Changed 6 years ago by sayamindu

  • cc cscott added

We have some translations and a POT file (eg: for Spanish, we have: https://dev.laptop.org/translate/es/glucose/sugar-update-control.po?translate=1&view=1)

I will take care of pushing them in tomorrow morning (IST), since I am too sleepy and might mess up something if I try to do a mass push now.

Scott, meanwhile, could you allow the pootle user to write to the particular repository in which the updater is stored ?

Changed 6 years ago by mstone-xmlrpc

  • keywords cjbfor9.1.0 added
  • milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

Changed 6 years ago by mstone

  • next_action changed from never set to package
  • milestone changed from 9.1.0 to 8.2.1

I have updated the permissions on /git/users/cscott/sugar-update-control on crank by ensuring that all files are owned by group 'sugar' (of which 'pootle' is a member) and that all dirs are setgid. Please push away!

Changed 6 years ago by sayamindu

Thanks Michael. I've committed all the files. There are some fuzzy translations for Spanish, which Rafael is taking care of at this very moment. I'll update this ticket as soon as the Spanish translations get updated.

Changed 6 years ago by sayamindu

  • cc sayamindu added; cscott removed
  • owner changed from sayamindu to cscott

..and we have complete and up to date Spanish translations (unless strings have changed). Scott could you package this ?

Changed 6 years ago by edmcnierney

  • keywords 8.2.1:+ added

Changed 6 years ago by cjb

  • owner changed from cscott to cjb
  • status changed from new to assigned
  • next_action changed from package to test in build

I've packaged this as sugar-update-control 0.18, using Scott's makefiles, and I'll throw it into Joyride now. (Since the new release with Spanish translation should be an improvement for everyone, provided I didn't break anything.)

Changed 6 years ago by cjb

  • cc cscott added

Sigh, not so fast. The build is failing, because right at the end:

cannot remove `/var/tmp/sugar-update-control-0.18-1-root-mockbuild/usr/lib/python2.5/site-packages/bitfrost/update/init.py*': No such file or directory

This attempted rm is specified in the specfile:

# avoid conflicts
rm $RPM_BUILD_ROOT/usr/lib/python2.5/site-packages/{bitfrost,bitfrost/update,bitfrost/util}/__init__.py*

bitfrost/update/init.py doesn't exist, so the rm fails.

I've pushed the changes that constitute the release, so we're just waiting on a successful mock build using them.

Changed 6 years ago by cscott

Released sugar-update-0.17.1 for 8.2.x and sugar-update-0.19 for 9.1. They are currently sitting in:

dev.laptop.org:~cscott/public_rpms/staging/sugar-update-control-0.17.1-1.src.rpm
dev.laptop.org:~cscott/public_rpms/staging/sugar-update-control-0.17.1.tar.gz
dev.laptop.org:~cscott/public_rpms/joyride/sugar-update-control-0.19-1.src.rpm
dev.laptop.org:~cscott/public_rpms/joyride/sugar-update-control-0.19.tar.gz

Please test.

Changed 6 years ago by cscott

The staging-4 (for 8.2.1) and joyride-2599 builds have updated sugar-update-control. Please set the laptop to Spanish and verify that all messages are translated.

Changed 6 years ago by sayamindu

I can verify that Joyride is working (except for the weird wrapping, which is documented in #8323). How do I download and check the staging builds ?

Changed 6 years ago by cscott

  • owner changed from cjb to cscott
  • status changed from assigned to new

Changed 6 years ago by dsd

  • next_action changed from test in build to finalize

verified fixed in staging-9, through this procedure:

* installed staging-9 using copy-nand on my US XO * in sugar, changed language to spanish and restarted * ran software updater and confirmed that it appeared in spanish

Changed 4 years ago by cjl

  • cc cjl added
  • status changed from new to closed
  • resolution set to fixed

I'm pretty sure this was fixed long ago. Closing as fixed.

Note: See TracTickets for help on using tickets.