Opened 6 years ago

Closed 5 years ago

#9105 closed defect (worksforme)

2583 Scrolling (e.g., "Page Up") gets multiplied

Reported by: mikus Owned by:
Priority: normal Milestone: Not Triaged
Component: not assigned Version: Development build as of this date
Keywords: Cc: mikus, mtd
Blocked By: Blocking:
Deployments affected: Action Needed: reproduce
Verified: no

Description

This problem has existed for a long time, but has gotten much worse with 0.83 - particularly with the latest Joyride builds.

In Terminal, I often press "Page Up" (fn-uparrow) to review (older) information that has scrolled off the top of the screen. But instead of scrolling up one page for me, the screen often scrolls up multiple pages - sometimes up through the entire Terminal screen buffer. I often get that same symptom (the screen scrolls through multiple pages) when I put the cursor on the scrollbar and click the mouse button.

I do not know if the cause is related to #9103 - but for sure my "scrolling inputs" are being incorrectly multiplied.

Change History (7)

comment:1 Changed 6 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

comment:2 Changed 6 years ago by mikus

Have not been running long enough to tell whether or not this problem has been fixed, but in several hours of using 2631 have not seen a recurrence of this problem.

comment:3 Changed 6 years ago by mikus

I posted too soon. Rebooted the XO, and am now again seeing "Page Up" being multiplied. So the problem was not fixed by 2631.

comment:4 Changed 6 years ago by mtd

  • Cc mtd added

comment:5 Changed 5 years ago by Quozl

  • Action Needed changed from never set to reproduce
  • Keywords cjbfor9.1.0 removed
  • Milestone changed from 9.1.0-cancelled to 8.2.2

Re: comment on #9777.

Tested again ... this symptom does not reproduce on XO-1.5 with build os48, or XO-1 with build os8, using native keyboard Fn-Shift-Up and Fn-Shift-Down keystrokes, or USB keyboard Shift-Page-Up and Shift-Page-Dn keystrokes.

Do you still experience this symptom, Mikus? Is there a USB keyboard involved? Is there a correlation between the symptom and system load? Can you explain how to reproduce it?

comment:6 Changed 5 years ago by martin.langhoff

  • Milestone changed from 8.2.2 to Not Triaged

I use pgup/down on 8.2.x on XO-1s and on recent builds on XO-1.5s.

Cannot reproduce any issues related to this.

Changing to 'not triaged' because it's not reported against 8.2.1, but against very old joyrides.

Quozl: I think it's just a stale bug against a random joyride... (won'tfix/worksforme?)

comment:7 Changed 5 years ago by Quozl

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.