Opened 6 years ago

Closed 3 years ago

#9153 closed defect (fixed)

XO no longer tries to connect wlan after resume from suspend

Reported by: thomaswamm Owned by: dcbw
Priority: normal Milestone: Not Triaged
Component: network manager Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

8.2-767 & Q2E18 official build, with Firefox-6 running.

In a multiday intermittent websurfing session with Firefox-6, I often suspend my XO (using powerbutton). Normally, after I resume from suspend (using powerbutton), my XO will reconnect to my wlan Access Point within a few minutes (it looks for school mesh first).

But today, I notice that the XO does not automatically try to reconnect after resume. I have to manually click on my AP icon in Neighbourhood View to reconnect. This failure to automatically reconnect after resume was reproducible several times. Screenshot & logs coming.

Attachments (2)

tmp0_BBYM.png (43.8 KB) - added by thomaswamm 6 years ago.
Screenshot - wlan does not automatically reconnect after resume from suspend.
logs.CSN7500144C.2008-12-29.02-24-39.tar.bz2 (154.7 KB) - added by thomaswamm 6 years ago.
olpc-log taken after XO did not try to reconnect wlan after resume from suspend.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by thomaswamm

Screenshot - wlan does not automatically reconnect after resume from suspend.

Changed 6 years ago by thomaswamm

olpc-log taken after XO did not try to reconnect wlan after resume from suspend.

comment:1 Changed 6 years ago by thomaswamm

After Restart, my XO is back to normal: it automatically reconnected to my AP after resume from suspend.

comment:2 Changed 6 years ago by thomaswamm

I just realized that this is a beneficial bug for me, because I can manually reconnect faster than the XO can automatically reconnect (because it takes so long trying to find a mesh before it tries my normal Access Point).

So if anyone learns what caused this bug, please let me know so that I can maybe make it happen on demand.

comment:3 follow-up: Changed 6 years ago by cjb

Thomas, there's nothing stopping you from clicking on your AP after every suspend to avoid the delay. When you click on the AP after resume, the attempts to find a mesh will be halted and a connection to the AP will happen.

comment:4 in reply to: ↑ 3 Changed 6 years ago by thomaswamm

Replying to cjb:

Thomas, there's nothing stopping you from clicking on your AP after every suspend to avoid the delay. When you click on the AP after resume, the attempts to find a mesh will be halted and a connection to the AP will happen.

That's not totally true... see #8592. Until a few other bugs get fixed, it is better to just wait for the XO to automatically reconnect after resume from suspend.

comment:5 Changed 3 years ago by Quozl

  • Action Needed changed from reproduce to no action
  • Resolution set to fixed
  • Status changed from new to closed

Believe this is fixed in 11.3.0, please upgrade.

Note: See TracTickets for help on using tickets.