Opened 6 years ago

Closed 4 years ago

#9181 closed defect (fixed)

COPYING file is missed

Reported by: alsroot Owned by: Quozl
Priority: normal Milestone: 11.2.0-final
Component: pippy-activity Version: 1.5 Software Build os206 aka 10.1.1
Keywords: Cc: anish@…
Blocked By: #10395 Blocking:
Deployments affected: Action Needed: add to build
Verified: no

Description


Change History (25)

comment:1 Changed 5 years ago by Quozl

  • Action Needed changed from never set to code
  • Milestone changed from Not Triaged to 1.5-future
  • Owner changed from cjb to Quozl
  • Status changed from new to assigned
  • Version changed from not specified to Development source as of this date

SL #1571 raised.

comment:2 Changed 5 years ago by Quozl

  • Milestone changed from 1.5-future to 1.5-software-update

comment:3 Changed 5 years ago by Quozl

No progress on SL 1571.

comment:4 Changed 5 years ago by Quozl

Patch proposed on SL 1571.

comment:5 Changed 5 years ago by Quozl

No progress on SL 1571.

comment:6 Changed 5 years ago by Quozl

No progress on SL 1571.

comment:7 Changed 4 years ago by Quozl

  • Action Needed changed from code to review

New patch submission by mailing list process detected, submitted my SL 1571 patch and am working with reviewers.

comment:8 Changed 4 years ago by Quozl

  • Action Needed changed from review to package

Patch accepted by maintainer and pushed. Waiting for maintainer to do release.

comment:9 Changed 4 years ago by Quozl

  • Action Needed changed from package to add to build

Maintainer has done a release, Pippy-36 contains the fix, and can be downloaded using Browse on os125. After download the COPYING file is present. The activity functions properly.

http://wiki.laptop.org/go/Activities/G1G1/10.1.1 needs to be updated with new download URL and bundle version (I've no access):

{{Activity-oneline
|icon = activity-pippy.svg|40px
|activity_name = Pippy
|activity_description = Python Programming language/environment 
|activity_id = org.laptop.Pippy
|activity_bundle = pippy-36.xo
|activity_bundle_url =   http://activities.sugarlabs.org/en-US/sugar/downloads/file/26913/pippy-36.xo
|activity_bundle_branch =  Pippy (latest)
|activity_version = 36
}}

The changelog of the activity contains:

  • Add COPYING based on activity.info license field, verify source file licenses, include LICENSE from Elements upstream SVN, fixes Sugarlabs.org # 1571 and laptop.org #9181. (James Cameron)
  • Fixed pippy layout so that it doesn't break at any resolution other than 1200x900. (Anish Mangal)
  • Moved the start, stop and run buttons to the activity toolbar. (Anish Mangal)

comment:10 Changed 4 years ago by Quozl

  • Milestone changed from 1.5-software-later to 10.1.2

Pippy-36 tested on os301 using download from activities.sugarlabs.org.
Please add to build.

comment:11 Changed 4 years ago by dsd

This version introduces a regression where the Stop and Keep buttons are pushed off the toolbar, only available in a somewhat non-obvious menu. XO-1 10.1.2 build 301 with system locale in spanish.

comment:12 Changed 4 years ago by dsd

Also, the "Share with" functionality has disappeared. (it appears on the toolbar while the activity is loading, then vanishes)

comment:13 follow-up: Changed 4 years ago by Quozl

  • Action Needed changed from add to build to communicate

Pippy-36 is unsuitable due to regressions. Waiting for a suitable package from upstream.

comment:14 Changed 4 years ago by Quozl

  • Version changed from Development source as of this date to 1.5 Software Build os206 aka 10.1.1

comment:15 Changed 4 years ago by m_anish

  • Cc anish@… added

comment:16 in reply to: ↑ 13 Changed 4 years ago by m_anish

Replying to Quozl:

Pippy-36 is unsuitable due to regressions. Waiting for a suitable package from upstream.

Pippy-37 has the same regressions.

comment:17 Changed 4 years ago by erikos

So, the missing buttons in the toolbar is a space issue, there are just too many icons in the toolbar not something that could be solved over expands or similar. I would say, we should create a secondary toolbar containing the start-stop-clear functionality. In the new toolbar design they can go into the top toolbar again - as there is space as the activity ones (title, keep...) are in a subtoolbar. What do others think?

comment:18 Changed 4 years ago by dsd

  • Milestone changed from 10.1.2 to 10.1.3

Not a 8.2 regression, moving to next milestone

comment:19 Changed 4 years ago by Quozl

Tested Pippy-37 on 10.1.2 on XO-1, Keep and Stop are pushed off toolbar, but COPYING is present.

comment:20 Changed 4 years ago by Quozl

  • Blocked By 10395 added

comment:20 Changed 4 years ago by Quozl

  • Action Needed changed from communicate to add to build
  • Blocked By 10395 removed

Pippy-37 is an acceptable solution to this ticket, despite the regressions, and so I've opened a ticket for those regressions and set it to block this ticket.

comment:21 follow-up: Changed 4 years ago by Quozl

  • Blocked By 10395 added

comment:22 in reply to: ↑ 21 Changed 4 years ago by m_anish

Replying to Quozl:

Pippy-38 should be free of these regressions.

comment:23 Changed 4 years ago by Quozl

  • Milestone changed from 10.1.3 to 10.1.4

comment:24 Changed 4 years ago by dsd

  • Resolution set to fixed
  • Status changed from assigned to closed

Pippy-38 is present in 11.2.0 build 4

Note: See TracTickets for help on using tickets.