Ticket #9223 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Wireless does not work in latest 8.2.1

Reported by: mikus Owned by: cjb
Priority: blocker Milestone: Not Triaged
Component: not assigned Version: Development build as of this date
Keywords: 8.2.1 Cc: mikus, edmcnierney
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

[Don't know if this is same problem as #9222.] I don't have wireless at home. Went to visit a friend who has his own Access Point ("yucca"). No matter what I did, I COULD NOT CONNECT my staging-21 system to his Access Point. Basically, when I clicked (in Neighborhood View) on the "yucca" AP, that icon would pulse for a while, then eventually a mesh icon would start pulsing instead.

[Among the things I tried ::: 'ifconfig msh0 down'. Very soon thereafter msh0 was automatically reinstated (once I even saw the mesh's 169.whatever address being assigned to eth0 !!) ::: 'service NetworkManager stop'. The device for eth0 disappeared !! ::: 'ifconfig eth0 up yucca-range-address'. Could ping myself, but trying to ping yucca's IP got "host unreachable". NOTHING worked - I was never able to connect the staging-21 system to my friend's wireless AP.]

Attachments

21noconnect.tar.bz2 (0.7 MB) - added by mikus 6 years ago.
staging-21 - olpc-log after AP icon stopped pulsing after being clicked on
767connect.tar.bz2 (0.7 MB) - added by mikus 6 years ago.
767 - same hardware, identical setup except for which "version" booted. olpc-log taken after XO successfully connected to AP "yucca"
21after.tar.bz2 (0.6 MB) - added by mikus 6 years ago.
staging-21 - olpc-log taken after booting test version rather than 767. Clicking on AP icon did not result in the XO connecting to the AP.
21ether.tar.bz2 (0.5 MB) - added by mikus 6 years ago.
FYI. staging-21 - olpc-log taken back home after me plugging in ethernet adapter after XO booted. For an instant, Neighborhood View showed icons of XOs on ethernet -- then this XO tried all three mesh channels -- then this XO finally (automatically) connected to the ethernet
24ether.tar.bz2 (0.6 MB) - added by mikus 5 years ago.
FYI. staging-24 (with kernel fix) - olpc-log taken at home after me plugging in ethernet adapter after XO booted. Neighborhood View changed to show XOs on ethernet - and did *not* impose any scan of the mesh channels after the ethernet was plugged in.
26autoconn.tar.bz2 (0.7 MB) - added by mikus 5 years ago.
(staging-26) - booted XO, it automatically connected to WEP AP (the AP's key was left over in the XO from the last time I tried to use this wireless AP).
yucca.png (35.8 kB) - added by mikus 5 years ago.
(staging-26) - Neighborhood View demonstrating "autoconnection" (after being booted) by the XO.
nonmconfig.tar.bz2 (0.8 MB) - added by mikus 5 years ago.
(staging-26) - this time I erased the network manager configuration, then booted. When I clicked on the "yucca" icon in Neighborhood View, the XO prompted me for the key, then connected.

Change History

Changed 6 years ago by mikus

staging-21 - olpc-log after AP icon stopped pulsing after being clicked on

Changed 6 years ago by mikus

767 - same hardware, identical setup except for which "version" booted. olpc-log taken after XO successfully connected to AP "yucca"

Changed 6 years ago by mikus

staging-21 - olpc-log taken after booting test version rather than 767. Clicking on AP icon did not result in the XO connecting to the AP.

Changed 6 years ago by cjb

  • cc edmcnierney added

This looks like a duplicate of #9222, but let's not close it until we analyze the logs.

Changed 6 years ago by cjb

  • owner set to cjb

Changed 6 years ago by mikus

FYI. staging-21 - olpc-log taken back home after me plugging in ethernet adapter after XO booted. For an instant, Neighborhood View showed icons of XOs on ethernet -- then this XO tried all three mesh channels -- then this XO finally (automatically) connected to the ethernet

Changed 5 years ago by mikus

FYI. staging-24 (with kernel fix) - olpc-log taken at home after me plugging in ethernet adapter after XO booted. Neighborhood View changed to show XOs on ethernet - and did *not* impose any scan of the mesh channels after the ethernet was plugged in.

Changed 5 years ago by kimquirk

I loaded staging-24 on two laptops with q2e29a and tested connections to olpc-WPA, olpc-WPA2, canopy (WEP), and two non-encrypted AP.

Absolutely no problem with the non-encrypted APs. The other access points are only connecting at 50-80% of the time. I click on the WPA AP and add the passphrase; it may or may not connect nicely. If it doesn't connect the first time, it may give up and try other options (usually ending in mesh channel 1); or it may ask me for the key again.

There must be some timing-related problem, perhaps involved in all encryption associations, so it is really hit or miss.

I was able to successfully connect to all access points... but I had to try multiple times for some of them.

I would recommend lowering the priority on this bug since it is possible to connect, but keep it as 'high' priority that we try to understand how to make this experience much better for people. Most (all?) of our deployments are using no encryption, which is another reason it can probably be lowered.

Changed 5 years ago by mikus

  • status changed from new to closed
  • resolution set to fixed

Visited my friend again. This time, with staging-26, I was reliably able to connect to his AP.

I'm going to assume that the #9222 fix also fixed #9223.

Changed 5 years ago by mikus

(staging-26) - booted XO, it automatically connected to WEP AP (the AP's key was left over in the XO from the last time I tried to use this wireless AP).

Changed 5 years ago by mikus

(staging-26) - Neighborhood View demonstrating "autoconnection" (after being booted) by the XO.

Changed 5 years ago by mikus

(staging-26) - this time I erased the network manager configuration, then booted. When I clicked on the "yucca" icon in Neighborhood View, the XO prompted me for the key, then connected.

Note: See TracTickets for help on using tickets.