Ticket #9234 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Opening files from the Journal mangles their name

Reported by: karl Owned by: etoys
Priority: normal Milestone: Future Release
Component: etoys-activity Version: not specified
Keywords: Cc:
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

The name will show the objects Journal ID which is not very useful and a bit ugly. I'm not sure how to change this. Do we need to keep track of the ID ?

Change History

Changed 5 years ago by bert

Could you explain what you mean? The journal is ID-based, it does not have or preserve file names. How does that relate to Etoys?

Changed 5 years ago by karl

When I open a picture in Etoy from the Journal the pictures name in Etoy show the Journal ID.

Changed 5 years ago by bert

  • milestone changed from Not Triaged to Future Release

Ah, that's true. Yes, would be nice to fix this. The problem is that we re-use the file-dropping logic, and the file name we get from the datastore is that funny id. Maybe if we simply mangle the name instance variable of the drop stream ...

Changed 5 years ago by karl

Hm, I also have a issue when I try to open files programatically that I have no reference to them. It's probably the same issue, the drop handler do not return the value. Do you have a suggestion on how to change the logic for opening files ?

Changed 5 years ago by ScottWallace

Issue now entered on the Squeakland tracker as:

http://tracker.squeakland.org/browse/sq-200

Changed 4 years ago by bert

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.