Opened 5 years ago

Closed 4 years ago

#9375 closed defect (fixed)

scratch sounds are jumpy

Reported by: dsd Owned by: cjb
Priority: blocker Milestone: 10.1.1
Component: sugar Version: Development build as of this date
Keywords: os54 os203 Cc: bert
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

The cat meow is jumpy, as if the buffers aren't quite big enough or something. Probably a more general issue...

Attachments (1)

sqUnixSoundALSA.c (21.4 KB) - added by dmoco 5 years ago.
ALSA plugin with fix for freezing and sayamindu fix for scratchy sound

Download all attachments as: .zip

Change History (18)

comment:1 Changed 5 years ago by triagebot

  • Action Needed changed from never set to test in build
  • Milestone changed from 1.5-software to 1.5-software-final

changed by irc user Quozl:

comment:2 Changed 5 years ago by Quozl

  • Action Needed changed from test in build to diagnose
  • Keywords os54 added
  • Version changed from not specified to Development build as of this date

Triage. Reproduced on os54. Method:

  • start Scratch activity,
  • click on the Sound button on the top left collection of eight buttons,
  • drag a "play sound [ meow ]" directive from the bottom left area to the second bottom left area that has the tab label Scripts, a copy will be placed in the Scripts area,
  • double click on the copy of the directive, and the meow sound is played, and it is scratchy.

comment:3 Changed 5 years ago by Quozl

  • Milestone changed from 1.5-software-final to 1.5-software-update

Ticket moved out of 1.5-software-final to 1.5-software-update as a result of a software manufacturing release triage meeting. Per ed, dsd, cjb, reuben, quozl.

comment:4 Changed 5 years ago by dsd

the contributors program is sending an XO-1.5 B2 to a scratch developer who hopes to look into this in his free time

comment:5 Changed 5 years ago by sayamindu

Looks like an underlying squeak problem to me. Etoys shows the same symptoms. To reproduce:

  • Start Etoys
  • Click on Supplies -> Object Catalog -> Multimedia -> PianoKeyboard
  • Press any key on the keyboard for a long time


comment:6 Changed 5 years ago by sayamindu

  • Action Needed changed from diagnose to review
  • Cc bert added

Found a possible fix. Notified upstream:

http://tracker.squeakland.org/browse/SQ-638

comment:7 Changed 5 years ago by sayamindu

  • Action Needed changed from review to package

Upstream has committed the proposed fix (thanks to Bert for the quick turnaround) : http://squeakvm.org/svn/squeak/trunk/platforms/unix/ChangeLog

comment:8 Changed 5 years ago by dsd

  • Action Needed changed from package to test in build

squeak-vm-3.10.5-2.fc11 on its way to f11-updates-testing

comment:9 Changed 5 years ago by Quozl

  • Milestone changed from 1.5-software-later to 1.5-software-update

comment:10 Changed 5 years ago by cjb

test in os102

comment:11 Changed 5 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

Tested and fixed..much better sound.

comment:12 Changed 5 years ago by Quozl

  • Action Needed changed from test in build to reproduce
  • Keywords os203 added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Occurs on os203.

Changed 5 years ago by dmoco

ALSA plugin with fix for freezing and sayamindu fix for scratchy sound

comment:13 Changed 5 years ago by dmoco

Looks like keeping several versions of the VM source around has come back to bite me in the ass. Apologies to those testing my changes to do with freezing last month and finding sound playback was scratchy. I had convinced myself the source included Sayamindu's patch but it did not. Amended source for vm-sound-ALSA attached.

comment:14 Changed 5 years ago by cjb

  • Action Needed changed from reproduce to add to build
  • Owner changed from dsd to cjb
  • Priority changed from normal to blocker
  • Status changed from reopened to new

Raising to blocker so that we don't forget to take a fix for this.

comment:15 Changed 4 years ago by cjb

  • Action Needed changed from add to build to never set

test in os204

comment:16 Changed 4 years ago by Quozl

  • Action Needed changed from never set to test in build

comment:17 Changed 4 years ago by Quozl

  • Resolution set to fixed
  • Status changed from new to closed

Tested in os204 installed using fs-update, the meow sound is no longer jumpy, interrupted, or scratchy.

(Using olpc-update and Software update does not fix the issue, since there was no change to the activity version.)

Note: See TracTickets for help on using tickets.