Ticket #9407 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Xv doesn't work

Reported by: dsd Owned by: dsd
Priority: normal Milestone: 1.5-software-later
Component: x window system Version: not specified
Keywords: Cc: HaraldWelte@…, mikus
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

openchrome doesn't enable Xv on VX855. When you enable it with the attached patch, it is easy to make the system crash:

"gst-launch videotestsrc ! xvimagesink" opens up the gstreamer window as expected, it gets painted fully green, then the system immediately hangs. I can SSH in but the display is totally frozen. Not even killing X unfreezes the display.

2 new log messages appear in Xorg.0.log at the point of hang:

Freed 0 (pool 0) Freed 0 (pool 0)

Attachments

vx855-xv.patch Download (1.2 KB) - added by dsd 5 years ago.
olpc-dm-X.error.log Download (1.5 KB) - added by mikus 5 years ago.
Log. (It's normal for os34, except for the two 'Freed 0 (pool 0)' lines at the end)

Change History

Changed 5 years ago by dsd

  Changed 5 years ago by mikus

  • cc mikus added

  Changed 5 years ago by mikus

With os33, I experience the exact symptoms described by #9407. [With os32, mplayer/vlc did not hang the system.] When running mplayer, my bypass on os33 is to tell mplayer to use the 'x11' driver -- then I do not get the system hang (but the picture is smaller than I like).

Changed 5 years ago by mikus

Log. (It's normal for os34, except for the two 'Freed 0 (pool 0)' lines at the end)

  Changed 5 years ago by cjb

  • milestone changed from 1.5-software to 1.5-software-beta

  Changed 5 years ago by dsd

  • milestone changed from 1.5-software-beta to 1.5-software-update

Jon Nettleton reports that Xv is working on his local codebase but is not yet stable enough for distribution. He'll hopefully post an early version to the devel list for testing soon.

  Changed 5 years ago by csetlow

  • next_action changed from never set to add to build
  • blockedby 10061 added

cjb will package the new openchrome from #10061 and when he has done so he will set this ticket to 'test in build.'

follow-up: ↓ 7   Changed 5 years ago by cjb

  • next_action changed from add to build to test in build

test in os113

in reply to: ↑ 6   Changed 5 years ago by mikus

Replying to cjb:

test in os113

My criterion is how well the XO-1.5 plays "movies". With kernel-2.6.31_xo1.5-20100312.1740.1.olpc.bca5e9d.i586 installed in os112, 'Mplayer' plays movies as well as they are played on an XO-1. On that kernel, 'VLC' also plays movies for me on XO-1.5.

  Changed 5 years ago by cjb

It would be useful for you to check that this is also the case in os113.

  Changed 5 years ago by Quozl

Tested in os113:

  • "gst-launch videotestsrc ! xvimagesink" worked fine,
  • "mplayer  tv://" worked fine, though there was a periodic motion pause,
  • "mplayer file.ts", where file.ts was a half hour DVB-T filtered transport stream of a television broadcast at 25 fps 720x576 MPEG2 9500 kbps, worked fine.

  Changed 4 years ago by Quozl

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

Tested in os117, still works. Closing.

Note: See TracTickets for help on using tickets.