Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9526 closed defect (fixed)

Recording audio does not work

Reported by: sayamindu Owned by:
Priority: blocker Milestone:
Component: not assigned Version: Development build as of this date
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

Using arecord to record audio does not seem to work. First it complains about the workaround in #9414 and if the workaround is removed, the recording is almost unintelligible.

Change History (7)

comment:1 Changed 5 years ago by cjb

  • Priority changed from normal to blocker

Raising to blocker.

comment:2 Changed 5 years ago by sayamindu

  • Blocking 9527 added

comment:3 Changed 5 years ago by Quozl

  • Action Needed changed from never set to diagnose
  • Version changed from not specified to Development build as of this date

On os33, was unable to reproduce the unintelligible recording. Need more detail on what made it unintelligible.

On os33, was able to reproduce the complaint about the workaround in #9414.

ALSA lib pcm_dmix.c:949:(snd_pcm_dmix_open) \
The dmix plugin supports only playback stream
arecord: main:608: audio open error: \
Invalid argument

Also fiddled with .asoundrc and Activities/TamTamMini.activity/common/Config.py per #9414 but did not end up learning much.

Reproduced #9414 on os33.

The .asoundrc workaround in #9414 seems to add a slight latency to TamTamMini keyboard playing, but I did not measure it.

Config.py does show parameters used by TamTam to capture audio, and these parameters work if adjusted. The following arecord command captured useful and accurate audio:

arecord -f S16_LE -t wav -r 44100 -c 2 -D hw:0,0 test.wav

comment:4 Changed 5 years ago by dsd

  • Action Needed changed from diagnose to test in build

At a guess, the unintelligible quality is because you used the default arecord options, which are to record a low-quality sound.

Fixed this for the next build by using a cleaner hack to fix #9414.

Now we need to do some recording testing and also we have to test that my newer hack doesn't inadvertently affect TamTam.

comment:5 Changed 5 years ago by Quozl

  • Resolution set to fixed
  • Status changed from new to closed

Fix confirmed on os39, used arecord without options fine.
Closing #9526.
Reopened #9414, as TamTam has been affected.

comment:6 Changed 5 years ago by bert

  • Blocking 9527 removed

(In #9527) I opened #9724 for the freezes.

The sound quality is bad too, we should keep this open to investigate. I'm changing the title.

comment:7 Changed 5 years ago by anonymous

  • Milestone 1.5-software deleted

Milestone 1.5-software deleted

Note: See TracTickets for help on using tickets.