Ticket #9527 (new defect)

Opened 5 years ago

Last modified 3 years ago

Etoys: bad quality when recording audio

Reported by: bert Owned by: marco
Priority: normal Milestone: 11.3.0
Component: etoys-activity Version: not specified
Keywords: Cc: etoys
Action Needed: diagnose Verified: no
Deployments affected: Blocked By:
Blocking:

Description

os32: Works in Scratch which uses the same Squeak Virtual Machine, so in principle it should work in Etoys too. This was in the log:

ALSA lib pcm_dmix.c:949:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
start_SoundRecording: snd_pcm_open: invalid argument

followed by the Squeak error message.

Change History

Changed 5 years ago by sayamindu

  • blockedby 9526 added

Changed 4 years ago by Quozl

  • next_action changed from never set to reproduce

Ticket #9526 was closed.

Can you please write a test case for reproducing this in Scratch, or attempt to reproduce yourself on os39?

Changed 4 years ago by dsd

In os43 it works, but the quality is bad, it only records a few seconds, and freezes for a few seconds when you click stop. Bert saw this too. should we file a new bug about that and close this one?

Changed 4 years ago by bert

  • component changed from sugar to etoys-activity
  • blockedby 9526 removed
  • summary changed from Etoys: recording audio does not work to Etoys: bad quality when recording audio

I opened #9724 for the freezes.

The sound quality is bad too, we should keep this open to investigate. I'm changing the title.

Changed 4 years ago by triagebot

  • milestone changed from 1.5-software to 1.5-software-update

changed by irc user cjb:

Bert, I don't know if we can spend time on this before our release next week, but maybe we could help given some more debugging work to go on. Any ideas?

Changed 4 years ago by dmoco

PulseAudio is now working for Scratch. A new version will be sent to the Squeak VM maintainer in the next few days. Maybe this could be used in place of Squeaks ALSA driver?

Changed 4 years ago by Quozl

  • next_action changed from reproduce to diagnose

Etoys continues to hang on starting Record. os851 on XO-1.5.

Changed 4 years ago by Quozl

  • milestone changed from 1.5-software-later to 10.1.3

Changed 4 years ago by bert

Hopefully fixed in etoys-4.1.2390 by preferring pulse over oss (needs a squeak-vm package which includes the vm-sound-pulse module)

Changed 3 years ago by dsd

  • milestone changed from 11.2.0-M3 to 11.2.0-M4
Note: See TracTickets for help on using tickets.