Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9587 closed task (fixed)

fix olpc-netutils for F11

Reported by: martin.langhoff Owned by: martin.langhoff
Priority: normal Milestone:
Component: olpc-netutils Version: Development build as of this date
Keywords: os39 Cc: mikus, dsd
Blocked By: Blocking:
Deployments affected: Action Needed: reproduce
Verified: no

Description

The olpc-netutils package has important tools to diagnose and debug collaboration issues.

After installing the vanilla version from Fedora 11...

  • olpc-xos / sugar-xos does not work at all, complains about setting the DISPLAY variable.
  • olpc-netstatus fails to read the Nickname (tries to read /home/olpc/.sugar/default/config ) and build name (from /boot/olpc_build
  • olpc-connections errors out because msh0 isn't there -- should instead detect whether it exists
  • olpc-mesh should detect msh0 isn't there

Attachments (5)

sugar-xos.traceback (85 bytes) - added by mikus 5 years ago.
I got confused - this is the real console output from sugar-xos
olpc-xos.traceback (712 bytes) - added by mikus 5 years ago.
this is the utility_program error that most concerns me
olpc-connections.output (402 bytes) - added by mikus 5 years ago.
obviously system-configuration dependent -- this output does not help me
olpc-netstatus.output (1017 bytes) - added by mikus 5 years ago.
has obvious errors, including: kernel, nick, jabber. I've made my own scripts, to tell me things I'm interested in which are missing from olpc-netstatus.
qqcf (2.3 KB) - added by mikus 5 years ago.
FWIW: my "brute-force" script to show .gconf content (still needs to be able to parse out last token from path - right now username is "canned")

Download all attachments as: .zip

Change History (30)

comment:1 Changed 5 years ago by Quozl

  • Action Needed changed from never set to reproduce
  • Version changed from not specified to Development build as of this date

comment:2 Changed 5 years ago by dsd

lets fix/update this in git and release a new tarball before including it in the build

comment:3 Changed 5 years ago by martin.langhoff

Got some patches that work both on old XO OS and new XO OS - see http://dev.laptop.org/git/projects/olpc-netutils/log/

comment:4 Changed 5 years ago by martin.langhoff

dsd - I think it's ok to tag and release with my patches. Happy to do that.

My only doubt is that I am not sure if we want to build the rpm with our scripts, or use the scripts that Fedora uses -- see http://cvs.fedoraproject.org/viewvc/rpms/olpc-netutils/F-11/

Are you guys following a specific strategy wrt to building packages that are in Fedora already? Use Fedora scripts? Our scripts?

comment:5 Changed 5 years ago by martin.langhoff

Re-tested, tagged, built with our scripts; available in http://dev.laptop.org/~martin/public_rpms/f11/

comment:6 Changed 5 years ago by martin.langhoff

Next step: dsd or cjb to add olpc-netutils to the kickstart file...

comment:7 Changed 5 years ago by martin.langhoff

  • Action Needed changed from reproduce to add to build

comment:8 Changed 5 years ago by martin.langhoff

Note: it will drag in avahi-tools, adding about 58K

comment:9 Changed 5 years ago by cjb

  • Action Needed changed from add to build to test in build

Should be testable in os37.

comment:10 Changed 5 years ago by cjb

  • Action Needed changed from test in build to add to build

No, I'm wrong. Not added yet.

comment:11 Changed 5 years ago by dsd

  • Owner changed from Collabora to dsd

I'm working on this, just waiting on appropriate fedora access

comment:12 Changed 5 years ago by dsd

  • Action Needed changed from add to build to test in build

ready for next build

comment:13 follow-up: Changed 5 years ago by Quozl

  • Resolution set to fixed
  • Status changed from new to closed

Confirmed fixed in os39.
olpc-netutils is present.
Most of the commands work fine.
olpc-mesh naturally does not find msh0.

Closing.

comment:14 in reply to: ↑ 13 Changed 5 years ago by Quozl

  • Action Needed changed from test in build to diagnose
  • Component changed from telepathy-other to olpc-netutils
  • Keywords os39 added
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from Include olpc-netutils in build, fix to work on current env to fix olpc-netutils for F11

Mikus wrote on devel@:

It was kind of you to include these -- but despite the upbeat
comments in #9587, of the eight utilities in this package:
two show no output; four omit some information (and get back
errors from some of the things they invoke); two produce
appropriate output.

In particular, in 2008 I found 'sugar-xos' *very* helpful in
letting me know what other nodes my system was seeing. But I
don't know enough about Linux to be able to fix 'sugar-xos'
so it works in F11.

Reopening, as getting it in the build is only half the bug. Changed summary, as scope has reduced.

comment:15 Changed 5 years ago by Quozl

Test of olpc-netutils scripts on os39, bound to local access point, connected to default jabber server.

scriptresult
/usr/bin/olpc-connectionsgood output
/usr/bin/olpc-logfails to proceed due to rm(1) prompts
/usr/bin/olpc-meshNo msh0 device! with non-zero exit status, is expected output, this is not a valid command for systems without msh0
/usr/bin/olpc-mppnot relevant, no mesh portal support on build
/usr/bin/olpc-netstatusgood output
/usr/bin/olpc-xosgood output
/usr/bin/sugar-telepathiesgood output
/usr/bin/sugar-xosgood output

Unable to reproduce Mikus' experience.

comment:16 Changed 5 years ago by Quozl

  • Action Needed changed from diagnose to reproduce
  • Cc mikus added

Correction, olpc-log works fine when run as root. It should not be run as user olpc.

Changed next action to reproduce ... need to find out what fails for Mikus, how it fails, and whether it is caused by something unique to his environment.

comment:17 Changed 5 years ago by mikus

My two good outputs: olpc-mesh and olpc-log

My "no output shown": olpc-mpp and sugar-telepathies

Changed 5 years ago by mikus

I got confused - this is the real console output from sugar-xos

Changed 5 years ago by mikus

this is the utility_program error that most concerns me

Changed 5 years ago by mikus

obviously system-configuration dependent -- this output does not help me

Changed 5 years ago by mikus

has obvious errors, including: kernel, nick, jabber. I've made my own scripts, to tell me things I'm interested in which are missing from olpc-netstatus.

Changed 5 years ago by mikus

FWIW: my "brute-force" script to show .gconf content (still needs to be able to parse out last token from path - right now username is "canned")

comment:18 follow-up: Changed 5 years ago by Quozl

Retesting olpc-netutils scripts that Mikus mentioned above, on 802 and os39, shows a regression in os39 in that several scripts do not work in a text console as user root.

Mikus' output shows a different shell prompt, suggesting other customisation may have been done. PATH is not properly set in his run of olpc-connections. DISPLAY is not properly set in his run of sugar-xos, olpc-xos and olpc-netstatus. I don't think I need to uncover the exact differences; it is clear that the environment differs.

My test results:

methodbuild 802build os39
as user olpc in Terminal activityworksworks
as user root in Terminal activityworksworks
as user olpc in text consoleworksfails, X11 related error
as user olpc in text console with DISPLAY definedworksworks
as user root in text consoleworksfails, X11 related error
as user root in text console with DISPLAY definedworksfails, DBus related error

Some further diagnosis without adequate knowledge follows:

The environment variables in the root shell on the text console were compared; the only differences were:

  • INPUTRC is present on 802 and absent on os39,
  • SSH_ASKPASS is absent on 802 and present on os39.

The HOME directory of the root shells were compared:

  • os39 has /root/.dbus, 802 does not.

The /etc/dbus-1 directories and process lists were compared:

  • 802 has a session-olpc.conf but os39 does not.
  • 802 has a dbus-daemon using the session-olpc.conf but os39 does not.

Some of these differences are probably irrelevant, perhaps DBus has changed.

comment:19 Changed 5 years ago by dsd

  • Owner changed from dsd to martin.langhoff
  • Status changed from reopened to new

he who touched it last receives all bugs for all eternity
;)

comment:20 follow-up: Changed 5 years ago by martin.langhoff

  • Cc dsd added

Hang on in there. With _my_ package, these bugs do _not_ appear. Daniel, you touched it last ;-)

Testing a bit on my os34...

  • my package works ok (test it with rpm -Uvhf http://dev.laptop.org/~martin/public_rpms/f11/olpc-netutils-0.7-1.olpc3.noarch.rpm)
  • upgrading to the 0.8-1 package from updates-testing works ok

Just to be sure, I tested sugar-xos/olpc-xos as follows

Under Terminal.xo:

  • Works - running as olpc, and running as root via sudo, with no need for ENV manipulation
  • Works - using salut and when using gabble

Under a VT ("text console"): These utilities will _not_ work in a VT or in an ssh session.

IMHO, this is a separate issue issue, affecting anything that wants to connect to dbus from a VT session.

comment:21 in reply to: ↑ 20 Changed 5 years ago by mikus

Replying to martin.langhoff:

Under Terminal.xo:

  • Works - running as olpc, and running as root via sudo, with no need for ENV manipulation
  • Works - using salut and when using gabble


Under a VT ("text console"): These utilities will _not_ work in a VT or in an ssh session.

IMHO, this is a separate issue issue, affecting anything that wants to connect to dbus from a VT session.


O.K. - now I understand what is happening to me. The clue is that olpc-xos works for user olpc, but does not work in a VT.

In 802, I used olpc-xos as root, and it worked for me. In F11, olpc-xos works only as olpc, not as root. [I switched from root to user olpc on my XO-1.5 system, and now olpc-xos did work for me.]


How can I set up whatever 'dbus' needs to work under userid zero ?

comment:22 in reply to: ↑ 18 ; follow-up: Changed 5 years ago by mikus

Replying to Quozl:


Mikus' output shows a different shell prompt, suggesting other customisation may have been done. PATH is not properly set in his run of olpc-connections. DISPLAY is not properly set in his run of sugar-xos, olpc-xos and olpc-netstatus. I don't think I need to uncover the exact differences; it is clear that the environment differs.


All I've done to PATH is to add subdirectories for useful scripts. And I've never touched DISPLAY - its value is whatever the system has set.

You say that these two are not properly set. So far, I haven't been able to figure out what's wrong. Please - give me a clue as to what you think is not right with them:

0 [olpc]# echo $PATH
/usr/local/sbin:/usr/sbin:/sbin:/usr/kerberos/sbin:
/media/080b24e0-a27c-4f8d-8d9b-7f7aaf1468af/utl/bin/utl:
/media/080b24e0-a27c-4f8d-8d9b-7f7aaf1468af/utl/bin:
/media/080b24e0-a27c-4f8d-8d9b-7f7aaf1468af/utl/bin/hlp:
/media/080b24e0-a27c-4f8d-8d9b-7f7aaf1468af/utl/bin/mum:
/usr/local/sbin:/usr/sbin:/sbin:/usr/lib/qt-3.3/bin:
/usr/kerberos/bin:
/home/olpc/Activities/Terminal.activity/bin:
/usr/bin:/bin
0 [olpc]# echo $DISPLAY
:0
0 [olpc]#

comment:23 in reply to: ↑ 22 Changed 5 years ago by Quozl

Replying to mikus:

You say that these two are not properly set. So far, I haven't been able to figure out what's wrong. Please - give me a clue as to what you think is not right with them.

I was wrong about PATH, I was interpreting attachment:olpc-connections.output incorrectly. It seems to be failing because it cannot handle eth1. I thought it was failing because sbin was not in path.

DISPLAY is reported not to be set attachment:sugar-xos.traceback

Glad to see you've checked them.

The prompt is different though, which caused me to consider other potential differences more carefully.

comment:24 Changed 5 years ago by martin.langhoff

  • Resolution set to fixed
  • Status changed from new to closed

Opened #9665 to track the use of dbus in utilities from a VT (the failures Mikus reported).

The orig problem with olpc-netutils is fixed, so closing.

comment:25 Changed 5 years ago by anonymous

  • Milestone 1.5-software deleted

Milestone 1.5-software deleted

Note: See TracTickets for help on using tickets.