Ticket #959 (closed enhancement: wontfix)

Opened 7 years ago

Last modified 5 years ago

Trackpad doesn't produce mouse clicks when tapped

Reported by: gnu Owned by: jg
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: hardware Version:
Keywords: trackpad tap click Cc: mstone, Blaketh, mtd
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

I don't know whether it's hardware or software -- or a deliberate design choice versus a defect that got lost among all the other touchpad troubles.

I've gotten used to touchpads on my laptops that let you tap the touchpad to generate a left-mouse-click. This means you can not only drag the mouse around, but also do 90% of your clicking, without your index finger leaving the pad. For human interface it's a win. (It's also close to the expected user interface for touchscreens, if and when we make one.) I tried it on XO and it doesn't work.

B2, FW Q2B61, Build 239, S/N SHF 706001D5.

Change History

Changed 7 years ago by jg

  • owner changed from mlj to jg
  • milestone changed from Untriaged to BTest-3

No, until recently, we haven't had a stable enough touch pad/driver to see if we could implement this.

I'll do some experiments to see if it looks feasible.

Changed 7 years ago by kimquirk

  • type changed from defect to enhancement
  • milestone changed from Trial-2 to FRS

There are many mousepads that don't produce clicks... like my MacBookPro. Not sure this is a requested feature.

I recommend we wait on this feature until there is feedback from the field or another feature, which is user-settable preferences.

Changed 7 years ago by warp

I have a feeling that this is more likely to be a Gen-2 issue, as the current touchpads simply don't offer the range of pressure sensing needed to do this by anything other then timing.

Specificly, normal touching pressure generally maxes out the pressure sensor, making it hard to tell brief firm taps from other things.

There are some things we could try, purely timing related testing, requiring a firm tap or a tap by fingernail and detecting based on a very brief switch to PT mode (a very firm push, or a touch with the fingernail, may trigger this reliable enough, though we wouldn't have dragging at all), that sort of thing.

Aside from the PT switch detection, this is all in xf86-input-evdev programming wise, but I simply don't see a good reliable way to do it right now.

Suggestions would be welcome.

Changed 6 years ago by ixo

On current (joyride 1702) MP XO Laptops, the touchpad has the ability to sense when I touch with two fingers... and alternatively tap them. So likely, it could be implemented with latest equipment.

FYI, this is the number one question, when anyone else uses my laptop. "What doesn't the double-tap work for a mouse click?" I answer: "It's by design"

Changed 6 years ago by mstone

  • cc mstone, Blaketh added

Changed 6 years ago by mtd

  • cc mtd added

Changed 5 years ago by rsmith

  • status changed from new to closed
  • next_action set to never set
  • resolution set to wontfix

Feature is enabled by default on CL1A laptops. (Thats a Gen 1 with the synaptics touchopad) and feedback from the field is that its a misfeature. Will be disabled in Gen 1.5 at some point.

Note: See TracTickets for help on using tickets.