Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#9628 closed defect (fixed)

test backup boot

Reported by: dsd Owned by: Quozl
Priority: high Milestone: 10.1.0
Component: initramfs Version: not specified
Keywords: Cc:
Blocked By: #9573 Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description (last modified by Quozl)

Haven't yet tested circle-key backup boot with new initramfs and partition setup

Change History (15)

comment:1 Changed 5 years ago by Quozl

  • Action Needed changed from never set to reproduce

triage.

comment:2 Changed 5 years ago by dsd

  • Blocked By 9573 added

This doesn't work yet, at least not in unsecure mode, because we don't have the olpc.fth logic that was provided by the bootfw package in earlier OS releases.

comment:3 Changed 5 years ago by dsd

  • Action Needed changed from reproduce to test in build

ready for testing in next build (although we'll need 2 more, so that there are 2 fixed OS builds that can be switched between)

comment:4 Changed 5 years ago by triagebot

  • Milestone changed from 1.5-software to 1.5-software-final

changed by irc user Quozl:

comment:5 Changed 5 years ago by Quozl

waiting for os53

comment:6 Changed 5 years ago by Quozl

  • Owner changed from dsd to Quozl
  • Status changed from new to assigned

tested after olpc-update from os51 to os52, the alternate boot request results in os52 ... presumably a good negative test. continuing to wait for os53.

comment:7 Changed 5 years ago by dsd

Doesn't quite work properly yet - there are issues with mktemp in the initramfs, and even after fixing that the boot symlink is not updated.

comment:8 Changed 5 years ago by cjb

  • Priority changed from normal to high

comment:9 Changed 5 years ago by Quozl

  • Action Needed changed from test in build to code

Indeed, doesn't work yet. Booted os53, olpc-update'd to os54, rebooted, verified os54 displayed, rebooted with square button, os54 was displayed instead of os53.

comment:10 Changed 5 years ago by dsd

  • Action Needed changed from code to test in build

fixed in dracut-modules-olpc-0.3.1 for next build

However, the alternate image that you boot into needs to have the fix in its initramfs, so we can't test this (without staging an environment) until we have 2 new builds.

btw, it is the circle key (not square) that triggers this

comment:11 Changed 5 years ago by Quozl

  • Description modified (diff)

Tested, on a unit with os54, did olpc-update to os55, successfully rebooted into os55, rebooted and pressed circle key, My Settings - About my computer now indicates build 54. Closing ticket.

comment:12 Changed 5 years ago by Quozl

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:13 Changed 5 years ago by dsd

  • Resolution fixed deleted
  • Status changed from closed to reopened

That's not a valid test - you have to reboot one more time to see if the change was actually written to disk. and in os54 that won't be, because it had a buggy initramfs.

Testing between os55 and os56 will be valid, i'll do that later today.

comment:14 Changed 5 years ago by dsd

  • Resolution set to fixed
  • Status changed from reopened to closed

yep, it works well

comment:15 Changed 4 years ago by Quozl

  • Action Needed changed from test in build to no action
Note: See TracTickets for help on using tickets.