Ticket #9749 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

improve olpc-update server selection logic

Reported by: dsd Owned by: dsd
Priority: normal Milestone: 10.1.0-beta
Component: upgrade utility Version: Development build as of this date
Keywords: Cc:
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

The current logic of choosing which server(s) to query is not really suitable for places where the OATS server is not the school server, but there are school servers online too.

In these situations there will be a responsive OATS server on the schoolserver, but the one we want them to contact is at a different address. With the current logic, the fact that the school server responds means that the other one is not tried.

Change History

Changed 4 years ago by Quozl

  • version changed from not specified to Development build as of this date

triage.

Changed 4 years ago by martin.langhoff

Hadn't seen this one.

I filed #9757 and #9758 (both addressed in git) to cover this issue for 8.2.2 . I think that the way I have addressed it is good for the F11 release too, reviews welcome.

Changed 4 years ago by dsd

  • next_action changed from code to package

Changed 4 years ago by dsd

  • next_action changed from package to test in build

released in olpc-update-2.21-1.fc11.noarch

Changed 4 years ago by Quozl

  • milestone changed from 1.5-software to 1.5-software-beta

retriage.

Changed 4 years ago by Quozl

confirmed that olpc-update-2.21-1.fc11.noarch is present on os51, but other than that no idea how to test. have we a test plan or a tester?

Changed 4 years ago by dsd

  • status changed from new to closed
  • resolution set to fixed

seems to be working, i just played with the /security/oats-ignore-xs and /security/oats-server files

Changed 4 years ago by Quozl

  • next_action changed from test in build to no action
Note: See TracTickets for help on using tickets.