Ticket #9968 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

1.5 Activity Pack changed to G1G1?

Reported by: reuben Owned by: dsd
Priority: normal Milestone: 10.1.1
Component: not assigned Version: not specified
Keywords: Cc:
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Build 105

Change History

Changed 4 years ago by dsd

whats this bug about?

Changed 4 years ago by reuben

The software updater now references the G1G1 activity pack. We previously referenced the F11 activity pack. Why did this change.

Changed 4 years ago by Quozl

  • status changed from new to closed
  • resolution set to duplicate

It changed due to #9939, patch ddaaaefc7fd5ee89b6c6832ab0efdfb0b3f8af29, and this is unfinished work that is expected to be completed closer to release, so I'll close this ticket as a duplicate of #9939.

Changed 4 years ago by dsd

Nothing changed, we've always been pointed at Activities/G1G1 - there was never a "F11 activity pack"

Perhaps you're simply seeing the effects that there is not yet a 10.2 collection.

Changed 4 years ago by reuben

You're correct. I looked back and we have always pointed to the G1G1. It seems counter intuitive that we point to Activities/G1G1/10.1 (previously Activities/G1G1/11.0) for the creation of the build and not specify to the same URL for the activity pack??

Changed 4 years ago by dsd

The behaviour is the same everywhere that the group URL is used. In both the build system and the sugar update control panel, it first tries /<buildnum> then /<majnum>.<minnum>.<relnum> then /<majnum>.<minnum> then /

Changed 4 years ago by dsd

well, you're right, it was hardcoded for 10.1. but that is now something that we've fixed with olpc-os-builder, see e.g. http://dev.laptop.org/git/projects/olpc-os-builder/tree/examples/olpc-os-10.1.0-xo1.5.ini#n68

Note: See TracTickets for help on using tickets.