Ticket #9982 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

locale-archive file huge

Reported by: sayamindu Owned by: sayamindu
Priority: normal Milestone: 1.5-software-later
Component: localization Version: 1.5 Software Build os64 aka 10.1.0
Keywords: Cc: cjb
Action Needed: review Verified: no
Deployments affected: Blocked By:
Blocking:

Description

We should probably consider selectively shipping locale information to conserve space.

Attachments

0001-Avoid-shipping-all-locales.patch Download (0.9 KB) - added by sayamindu 5 years ago.
Patch which cuts down the file size by around 50 megs

Change History

  Changed 5 years ago by Quozl

  • next_action changed from never set to diagnose
  • version changed from not specified to 1.5 Software Build os64 aka 10.1.0
  • milestone changed from Not Triaged to 1.5-software-later

Changed 5 years ago by sayamindu

Patch which cuts down the file size by around 50 megs

  Changed 5 years ago by sayamindu

  • cc cjb added
  • next_action changed from diagnose to review

Chris, does the attached patch look OK to you ? (it is based on the link you sent:  http://www.mail-archive.com/fedora-livecd-list@redhat.com/msg03195.html)

(we can trim a bit more, but I would like to be a bit cautious here - when I tried to run the commands on a live machine, most of the apps crashed)

  Changed 5 years ago by cjb

Looks okay. Does that trim from /usr/share/locale as well, or just the /usr/lib/locale/locale-archive?

I'll check with Ed about whether we could avoid shipping some of the remaining languages (German, Chinese, Japanese, etc) in the default image -- if there are tens of megabytes of savings available, I think that could make it justified to prepare separate images if we deploy in those languages in the future.

follow-up: ↓ 5   Changed 5 years ago by sayamindu

Could you possibly push this ?

It does not take care of /usr/share/locale, but I think the files in /usr/share/locale should be left in the builds, since if we need to add support for a locale at deployment site, localedef would get the definitions from files in /usr/share/locale

As for pruning German, etc, I think we should definitely do it if it can be confirmed that we do not need it immediately.

in reply to: ↑ 4 ; follow-up: ↓ 6   Changed 5 years ago by cjb

Replying to sayamindu:

Could you possibly push this ?

Yes, will give it a try.

It does not take care of /usr/share/locale, but I think the files in /usr/share/locale should be left in the builds, since if we need to add support for a locale at deployment site, localedef would get the definitions from files in /usr/share/locale

I think the answer depends on how much disk space is involved. I don't agree that we should necessarily spend tens of megs shipping strings for locales we're extremely unlikely to need.

As for pruning German, etc, I think we should definitely do it if it can be confirmed that we do not need it immediately.

Cool, okay.

in reply to: ↑ 5 ; follow-up: ↓ 7   Changed 5 years ago by sayamindu

Replying to cjb:

Replying to sayamindu:

Could you possibly push this ?

Yes, will give it a try.

Thanks!

It does not take care of /usr/share/locale, but I think the files in /usr/share/locale should be left in the builds, since if we need to add support for a locale at deployment site, localedef would get the definitions from files in /usr/share/locale

I think the answer depends on how much disk space is involved. I don't agree that we should necessarily spend tens of megs shipping strings for locales we're extremely unlikely to need.

Oops - I'm sorry. I confused between /usr/share/locale and /usr/share/i18n. We already prune /usr/share/locale in the build process (all translations except those mentioned in the ini files are removed). Of course, we can remove German, etc from that list as well.

/usr/share/i18n is the directory that stores the locale definition (not strings) which can be used to generate the localedata archive and its around 9.8 MB in size (it can be compressed to around 3.2 MB if required).

in reply to: ↑ 6   Changed 5 years ago by cjb

Replying to sayamindu:

Oops - I'm sorry. I confused between /usr/share/locale and /usr/share/i18n. We already prune /usr/share/locale in the build process (all translations except those mentioned in the ini files are removed). Of course, we can remove German, etc from that list as well.

Okay, will work out which langs use the most disk space/are least likely to ship and remove them from langs= in the config. Thanks!

/usr/share/i18n is the directory that stores the locale definition (not strings) which can be used to generate the localedata archive and its around 9.8 MB in size (it can be compressed to around 3.2 MB if required).

I see, will consider that later.

  Changed 5 years ago by cjb

Pushed, building os110 now.

I think it would be good to further remove en_* and zh_TW, but I don't see how to do that using langs=.

  Changed 4 years ago by dsd

  • status changed from new to closed
  • resolution set to fixed

fixed in recent builds - locale-archive is 17mb in 10.2.0 build 121

Note: See TracTickets for help on using tickets.