Opened 3 years ago

Closed 3 years ago

#11766 closed defect (fixed)

systemd doesn't remount / RO on shutdown

Reported by: dsd Owned by: dsd
Priority: normal Milestone: 12.1.0
Component: distro Version: not specified
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

During boot of 12.1.0 build 6 the system often complains that the ext4 root filesystem was not cleanly unmounted. OFW can also detect this condition. Check/fix this.

Change History (8)

comment:1 Changed 3 years ago by Quozl

11.3.1 also does not cleanly unmount the ext4 root filesystem.

comment:3 Changed 3 years ago by dsd

  • Action Needed changed from diagnose to communicate
  • Summary changed from check filesystem unmount on shutdown to systemd doesn't remount / RO on shutdown

comment:4 Changed 3 years ago by dsd

  • Action Needed changed from communicate to add to build

Not making much progress on that patch. Filed a bug upstream as https://bugs.freedesktop.org/show_bug.cgi?id=49447 and added a workaround in olpc-os-builder 6498241ea2e89041b73de50faa0741ec5a882427

comment:5 Changed 3 years ago by pbrobinson

  • Action Needed changed from add to build to test in build

comment:6 Changed 3 years ago by dsd

  • Action Needed changed from test in build to add to build

Not shipped in 12.1.0 build 9. Will be in the next one.

comment:7 Changed 3 years ago by dsd

  • Action Needed changed from add to build to test in build

Test in 12.1.0 build 10.

comment:8 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Verified in 12.1.0 os11 that /lib/systemd/system-shutdown/olpc_shutdown.sh was present on all three platforms.

Verified that a XO-1.75 with serial port remounted the root partition readonly on shutdown and did not report a need to fsck it on startup.

Note: See TracTickets for help on using tickets.