Opened 8 years ago

Closed 8 years ago

#2142 closed defect (fixed)

Fill function in Oficina does nothing.

Reported by: jfuhrer Owned by: alexandre
Priority: normal Milestone: Trial-2
Component: paint/drawing-activity (oficina) Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

OFW: Q2C18
Build: 505

The fill feature in Oficina is lagged to the point where it effectively does nothing. If you fill something and wait ~5 minutes, it will eventually do the fill you want. If you do anything in between, you will never get the fill.

Attachments (1)

Oficina.log (43.6 KB) - added by jfuhrer 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by jfuhrer

comment:1 Changed 8 years ago by alexandre

  • Component changed from pixel paint (obsolete) to paint (oficina)
  • Milestone changed from Untriaged to Trial-2
  • Owner changed from manu to alexandre

comment:2 Changed 8 years ago by lincolnquirk

looking at Desenho.py, I suspect the problem is related to pumping GTK events (line 443) during the execution of other GTK events. I don't know exactly how these handlers work but it seems like it would be problematic especially with the double buffering that gets done.

Can it be optimized by avoiding get_pixel and put_pixel and using Numeric arrays, or perhaps drawing lines at a time instead of pixels?

comment:3 Changed 8 years ago by alexandre

  • Status changed from new to assigned

This funtion was changed, but I don't know which build has that modification.

comment:4 Changed 8 years ago by pekayatt

  • Resolution set to fixed
  • Status changed from assigned to closed

new fill fuction, implemented on C module
now it's very quickly, take around 3 secs to fill 800X600 screen on B3...
we will try some new algoritms to make improvements

Note: See TracTickets for help on using tickets.