Ticket #2373 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Clicking on an AP in the mesh view didn't change XO connection

Reported by: kimquirk Owned by: dcbw
Priority: high Milestone: Trial-3
Component: network manager Version:
Keywords: Cc:
Action Needed: Verified: yes
Deployments affected: Blocked By:
Blocking:

Description (last modified by kimquirk) (diff)

B4, build 528.

I first booted up my XO at home where it couldn't find a school server. It had only local mesh connection and was able to find other local mesh laptops.

Then I clicked on my WEP enabled infrastructure AP, supplied the password, and it was able to connect.

The other laptops could no longer connect to this one, so decided to shut them all down and try again. After rebooting the first laptop could no longer connect to my WEP AP.

From the mesh view I clicked on an open AP in hopes that the problem was related to WEP, but the icon for the WEP AP continued to flash (like it was still trying); and the iwconfig showed that it was still connecting to the WEP AP.

Change History

Changed 7 years ago by kimquirk

  • description modified (diff)

Changed 7 years ago by dcbw

You know I need /var/log/messages from the affected machine :)

Also, it's a known limitation that if you have any laptop on an encrypted access point, none of the others will be able to find that laptop or use it as a mesh portal, precisely because it's encrypted. If there's an encrypted AP around, all laptops have to connect directly to the AP in infrastructure mode to get internet access.

Changed 7 years ago by jg

  • milestone changed from Untriaged to Trial-2

Hmmm.... I'm not convinced this necessarily has much to do with encryption: today I clicked on an access point decently recent build (say 515; I'd have to go check), and it did not connect; I had to repeat the operation before eventual success.

Changed 7 years ago by jg

  • milestone changed from Trial-2 to Trial-3

Changed 7 years ago by dcbw

The other laptops could no longer connect to this one, so decided to shut them all down and try again. Note that is expected; when one laptop is connected to an encrypted AP, no other laptops will be able to see or talk to that laptop.

Changed 7 years ago by kimquirk

  • status changed from new to closed
  • verified set
  • resolution set to fixed

I'm closing this bug as it works as designed for the WEP enabled AP; and other aspects of this bug are not longer a problem in later releases.

Note: See TracTickets for help on using tickets.