Opened 8 years ago

Closed 8 years ago

#2434 closed defect (worksforme)

One of my B4s can't get on the mesh today

Reported by: Zack Owned by: kimquirk
Priority: high Milestone: Future Release
Component: network manager Version:
Keywords: Cc: Zack
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description (last modified by Zack)

I have two B4s sitting next to each other with 530. The first one to boot won't get on the mesh; the icon blinks for 10ish seconds, and then stops blinking. It never gets an autoip address. Here's some info from /var/log/messages:

Jul 24 18:34:21 localhost NetworkManager: <info>  User Switch: /org/freedesktop/NetworkManager/Devices/msh0 
Jul 24 18:34:21 localhost NetworkManager: <info>  Deactivating device msh0. 
Jul 24 18:34:21 localhost avahi-daemon[1211]: Withdrawing address record for fe80::217:c4ff:fe03:56da on msh0.
Jul 24 18:34:21 localhost NetworkManager: <info>  aipd_cleanup(): called 
Jul 24 18:34:21 localhost NetworkManager: <info>  Device msh0 activation scheduled... 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0) started... 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0) Stage 1 of 5 (Device Prepare) scheduled... 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0) Stage 1 of 5 (Device Prepare) started... 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0) Stage 2 of 5 (Device Configure) scheduled... 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0) Stage 1 of 5 (Device Prepare) complete. 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0) Stage 2 of 5 (Device Configure) starting... 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0/mesh) level 4: Peer-to-Peer Mesh. 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0/mesh) Stage 2 of 6 (Device Configure) looking for a mesh on channel 1. 
Jul 24 18:34:21 localhost NetworkManager: <info>  Activation (msh0) Stage 2 of 5 (Device Configure) complete. 
Jul 24 18:34:22 localhost kernel: [ 4067.447790] ADDRCONF(NETDEV_CHANGE): msh0: link becomes ready
Jul 24 18:34:22 localhost NetworkManager: <info>  Old device 'msh0' activating, won't change. 
Jul 24 18:34:23 localhost NetworkManager: <info>  msh0: Got association; scheduling association handler 
Jul 24 18:34:23 localhost NetworkManager: <info>  msh0: got association event from driver. 
Jul 24 18:34:23 localhost NetworkManager: <info>  Activation (msh0) Stage 3 of 5 (IP Configure Start) scheduled. 
Jul 24 18:34:23 localhost NetworkManager: <info>  Activation (msh0) Stage 3 of 5 (IP Configure Start) started... 
Jul 24 18:34:23 localhost NetworkManager: <info>  aipd_exec(): returning success pid 1721 
Jul 24 18:34:23 localhost NetworkManager: <info>  Activation (msh0) Stage 3 of 5 (IP Configure Start) complete. 
Jul 24 18:34:24 localhost avahi-daemon[1211]: Registering new address record for fe80::217:c4ff:fe03:56da on msh0.*.
Jul 24 18:34:43 localhost NetworkManager: <info>  msh0: avahi-autoipd timed out. 
Jul 24 18:34:43 localhost NetworkManager: <info>  channel_failure_handler: step 4, channel 1, next channel -1  
Jul 24 18:34:43 localhost NetworkManager: <info>     will fail 
Jul 24 18:34:43 localhost NetworkManager: <info>  channel_failure_handler: failing activation 
Jul 24 18:34:43 localhost NetworkManager: <info>  Activation (msh0) failure scheduled... 
Jul 24 18:34:43 localhost NetworkManager: <info>  Activation (msh0) failed. 
Jul 24 18:34:43 localhost NetworkManager: <info>  Deactivating device msh0. 
Jul 24 18:34:43 localhost avahi-daemon[1211]: Withdrawing address record for fe80::217:c4ff:fe03:56da on msh0.
Jul 24 18:34:43 localhost NetworkManager: <info>  aipd_cleanup(): called 
Jul 24 18:34:43 localhost NetworkManager: <info>  aipd_cleanup(): Will kill avahi-autoipd pid 1721 

Attachments (1)

msgs (13.2 KB) - added by Zack 8 years ago.
/var/log/messages snippet

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by Zack

  • Description modified (diff)

comment:2 Changed 8 years ago by Zack

After a reboot, it's back on the mesh. I wonder what happened.

comment:3 Changed 8 years ago by jg

  • Milestone changed from Untriaged to Trial-2

Dan, any post mortem before we close this as unreproducible?

comment:4 Changed 8 years ago by dcbw

So the odd part is this:

Jul 24 18:34:43 localhost NetworkManager: <info> msh0: avahi-autoipd timed out.

can you try to run avahi-autoipd manually with the option to force-acquire an address and see if that works?

comment:5 Changed 8 years ago by Zack

Haven't been able to reproduce it yet, but I'll try that next time I see it.

comment:6 Changed 8 years ago by kimquirk

  • Owner changed from dcbw to Zack
  • Priority changed from blocker to high

Zack,
Please retry this, we believe it has been fixed in later builds.

comment:7 Changed 8 years ago by jg

  • Milestone changed from Trial-2 to Trial-3

Changed 8 years ago by Zack

/var/log/messages snippet

comment:8 Changed 8 years ago by Zack

  • Priority changed from high to blocker

Still happening, though I don't see "msh0: avahi-autoipd timed out." anymore. I ran 'avahi-autoipd --force-bind msh0' and it said that it successfully claimed 169.254.5.224, but ifconfig disagreed.

comment:9 Changed 8 years ago by Zack

The faulty B4 doesn't even seem to try the same channel that the other XOs (A B4 and a B3) are on.

comment:10 Changed 8 years ago by jg

  • Owner changed from Zack to kimquirk

Zack, please bring this machine in.

comment:11 Changed 8 years ago by Zack

Sure, Jim. You think it's a hardware bug? I have gotten it to talk to another B4 before.

comment:12 Changed 8 years ago by kimquirk

  • Milestone changed from Trial-3 to V1.1
  • Priority changed from blocker to high

Moving this out and lowering the priority since it likely to be a problem with one particular machine.

comment:13 Changed 8 years ago by kimquirk

  • Resolution set to worksforme
  • Status changed from new to closed

Never received this laptop. Closing this bug. We can reopen it if it shows up again.

Note: See TracTickets for help on using tickets.