Opened 8 years ago

Closed 4 years ago

#2588 closed defect (worksforme)

Sugar fails to start; infinite loop

Reported by: Zack Owned by: ixo
Priority: high Milestone: 9.1.0-cancelled
Component: network manager Version:
Keywords: cjbfor9.1.0 Cc: Zack, gregorio, dsd
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

After rebooting, sugar failed to start (and kept trying to, forever). I passed the laptop to Dan and I do believe he fixed it, but I'm opening this just to keep track.

Change History (9)

comment:1 Changed 8 years ago by Zack

  • Cc Zack added
  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 8 years ago by dcbw

Turned out to be a sugar bug in saved network config handling, fixed in sugar commit dbe8a6eeff7e2f42c309ba709038d568246f0853

comment:3 Changed 8 years ago by kimquirk

  • Milestone changed from Untriaged to Trial-2
  • Resolution fixed deleted
  • Status changed from closed to reopened

Not fixed in 540. What build did this get into? How do I fix it until the appropriate build gets released?

comment:4 Changed 8 years ago by jg

  • Milestone changed from Trial-2 to Trial-3

Has this gotten in a build, Dan?

comment:5 Changed 8 years ago by jg

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 Changed 7 years ago by ixo

  • Milestone changed from Trial-3 to Retriage, Please!
  • Resolution fixed deleted
  • Status changed from closed to reopened

I had a report of a user having this problem, when XO was auto-updated from 650 to 656.
Luckily, they were experienced enough to help track it down part of the way. A file permissional problem in .sugar/default/ directory. (i.e. they can rename the directory, and boots fine).

I can contact the user (was "User" in IRC) for more specific details, if need be.

comment:7 Changed 7 years ago by gregorio

  • Action Needed set to never set
  • Cc gregorio added
  • Owner changed from dcbw to ixo
  • Priority changed from blocker to high
  • Status changed from reopened to new

Hi Ixo,

Looks like Jim closed this as resolved. Can this be reproduced? I think many XOs were updated this way so let us know if you have exact steps to reproduce it.

Also, if its a problem only with 656 only and not with the latest, we probably have to let it go and say its fixed in the 8.2.0.

Thanks,

Greg S

comment:8 Changed 7 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

comment:9 Changed 4 years ago by dsd

  • Cc dsd added
  • Resolution set to worksforme
  • Status changed from new to closed

Need exact steps to reproduce this as requested above, if still valid.

Note: See TracTickets for help on using tickets.