Opened 8 years ago

Closed 8 years ago

Last modified 6 weeks ago

#3537 closed defect (duplicate)

Resume jumps to boot

Reported by: cjb Owned by: wmb@…
Priority: blocker Milestone:
Component: ofw - open firmware Version: Development build as of this date
Keywords: power Cc: wad, rsmith, jg
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

[    2.094745] pci 0000:00:01.0: LATE suspend
[    2.098852] platform lid: LATE suspend, may wakeup
[    2.103653] platform powerbutton: LATE suspend, may wakeup
[    2.109155] rtc_cmos rtc_cmos: LATE suspend, may wakeup
[    2.114682] olpc_do_sleep!
+r+
Forthmacs 
Type 'i' to interrupt stand-init sequence
First stand-init:

C-Test, Q2C26, went on to perform a normal boot. Happened after 5413 successful resumes. Mitch, maybe you could start us off with possible ways to try and debug this next time?

Change History (6)

comment:1 Changed 8 years ago by jg

  • Milestone changed from Untriaged to First Deployment, V1.0

comment:2 Changed 8 years ago by wad

We need the serial number of the offending unit.

I've seen this before when the cause was the #1835 ECO interacting badly with a brownout on the +3.3V line.

comment:3 Changed 8 years ago by wmb@…

  • Resolution set to duplicate
  • Status changed from new to closed

This is probably yet another manifestation of the power supply issues that wad has been addressing.

comment:4 Changed 8 years ago by wad

On B3/B4/C1 machines which have not had the Suspend ECO applied, this was seen occasionally.

On B3/B4/C1 machines which have had the Suspend ECO applied, this is almost certainly due to the CPU supervisor detecting a brownout and resetting the system. As this condition in itself is worrysome, I have taken machines showing this condition and modified them in one of two ways:

# added bulk capacitance to the +3.3V line
# replaced the CPU supervisor with the circuit we will use in production, which doesn't detect a low voltage condition.

We are monitoring these units to see if any additional reboots occur, or if the unit exhibits another problem.

comment:5 Changed 8 years ago by wad

Overnight testing saw the two units (63 and 81) with the bulk capacitance (100 uF added at C267) fail and reboot.

comment:6 Changed 6 weeks ago by Quozl

  • Milestone Update.1 deleted

Milestone Update.1 deleted

Note: See TracTickets for help on using tickets.